zoukankan      html  css  js  c++  java
  • 勇者斗恶龙 UVA 11292

    Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.

    The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance

    nce. One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom

    The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight’s height.”

    Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king.You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!

    INPUT

    The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres.

    The last test case is followed by a line containing ‘0 0’

    OUTPUT

    For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line ‘Loowater is doomed!’.

    SAMPLE INPUT

    2 3

    5

    4

    7

    8

    4

    2 1

    5

    10

    0 0

    SAMPLE OUTPUT

    11

    Loowater is doomed!

    题意:有一条龙有n个头,第i个头的直径为xi,城市里有m个勇者,第i个勇者可以砍下直径小于等于xi的龙的头颅,每个勇者只会挥剑一次,且收费yi,你想消灭这条恶龙,使用尽可能少的钱。。。。

    思路:量才而用,能力越大的勇者收费也就越高,那么就可以确定这样的贪心策略,每次都使用大于等于xi且值尽可能地小的那个勇士,还可以把勇者和龙头都从小到大排序,这样,前面被弃选的那些勇者也绝不可能被后面的龙头选上

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #define RPE(i,n) for(int i=1;i<=(n);i++)
    using namespace std;
    const int maxn=2e4+10;
    int a[maxn],b[maxn];
    int main()
    {
        int m,n;
        while(cin>>n>>m&&n)
        {
            RPE(i,n) cin>>a[i];
            RPE(i,m) cin>>b[i];
    
            sort(a+1,a+n+1);
            sort(b+1,b+m+1);
    
            int sum=0;
    
            int cnt=1;
            RPE(i,m)
            {
                if(b[i]>=a[cnt])
                {
                    sum+=b[i];
                    cnt++;
                }
                if(cnt>n) break;
            }
            if(cnt<=n) cout<<"Loowater is doomed!"<<endl;
            else       cout<<sum<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    人这一辈子
    理性不是逆来顺受
    旧瓶新酒:江城子
    HVAC专业相关网站
    韩寒:主子,奴才和狗
    百无一用是书生
    inove主题文章字体修改
    这个世界清净了:再见人人
    ActiveX控件开发(转)
    GIS大讲堂内所有讲座的索引(更新至2008年6月26日)(转)
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4796125.html
Copyright © 2011-2022 走看看