zoukankan      html  css  js  c++  java
  • The Falling Leaves(建树方法)

    uva 699

    紫书P159

    Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?


    We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

    The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

    Input 

    The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value -1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single -1(which would otherwise represent an empty tree).

    Output 

    For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

    Sample Input 

    5 7 -1 6 -1 -1 3 -1 -1
    8 2 9 -1 -1 6 5 -1 -1 12 -1
    -1 3 7 -1 -1 -1
    -1
    

    Sample Output 

    Case 1:
    7 11 3
    
    Case 2:
    9 7 21 15

    建树的过程可以很灵活,不要太过呆板

    #include <iostream>
    #include <cstring>
    using namespace std;
    const int maxn=200;
    int sum[maxn];
    
    void Build(int u)
    {
        int v;
        cin>>v;
        if(v==-1) return;
        sum[u]+=v;
        Build(u-1);
        Build(u+1);
    }
    
    bool Init()
    {
        memset(sum,0,sizeof(sum));
        int v;
        cin>>v;
        if(v==-1) return false;
        int pos=maxn/2;
        sum[pos]=v;
        Build(pos-1);
        Build(pos+1);
    }
    
    int ca=1;
    void Output()
    {
        int p=0;
        while(sum[p]==0) p++;
        cout<<"Case "<<ca++<<":
    "<<sum[p];
        while(sum[++p]!=0) {cout<<" "<<sum[p];}
        cout<<"
    
    ";
    }
    
    int main()
    {
        while(Init())
        {
         Output();
        }
        return 0;
    }
    View Code
  • 相关阅读:
    mysql 时间戳 转 时间
    VSCode搭建VUE 开发环境
    虚拟通信
    JavaScript 获取客户端计算机硬件及系统信息
    Thinkphp关联模型BELONGS_TO
    docker部署rancher踩坑篇
    青龙面板 脚本 依赖库下载安装
    Linux 随记
    Tekton DAG代码
    手写Spring valar
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/5002944.html
Copyright © 2011-2022 走看看