zoukankan      html  css  js  c++  java
  • 【HDU 3336】Count the string(KMP+DP)

    Problem Description


    It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
    s: "abab"
    The prefixes are: "a", "ab", "aba", "abab"
    For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
    The answer may be very large, so output the answer mod 10007.

    Input


    The first line is a single integer T, indicating the number of test cases.
    For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

    Output


    For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

    Sample Input

    1
    4
    abab
    

    Sample Output

    6
    

    题解


    考虑kmp算法中next数组的定义,即

    [f[i]=k;whilea[0....k]==a[k+1...j] ]

    那么我们就可以产生一个dp方程
    设dp[i]:已a[i]结尾的前缀数

    [dp[i]=dp[f[i]]+1 ]

    参考代码

    import java.io.*;
    import java.util.*;
    
    public class Main{
          static int N=200000+10;
          static int f[]=new int [N];
          static char a[]=new char[N];
          static void getFail(char b[],int m) {
        	  int j=0;
        	  f[1]=0;
        	  for(int i=2;i<=m;i++) {
        		  while(j>0&&b[j+1]!=b[i]) j=f[j];
        		  if(b[j+1]==b[i]) j++;
        		  f[i]=j;
        	  }
          }
          static int dp[]=new int[N];
          public static void main(String[] args){
              InputReader in=new InputReader(System.in);
              PrintWriter out=new PrintWriter(System.out);
              int T=in.nextInt();
              while(T--!=0) { 
                 int n=in.nextInt();
            	 String str=in.next();
            	 for(int i=0;i<n;i++) a[i+1]=str.charAt(i);
            	 getFail(a,n);
            	 Arrays.fill(dp, 0);
                 int ans=0;
            	 for(int i=1;i<=n;i++) {
            		 dp[i]=(dp[f[i]]+1)%10007;
                	 ans+=dp[i];
                	 ans%=10007;
                 }
                 out.println(ans);
                 out.flush();
              }
          }
    	static class InputReader {
            public BufferedReader reader;
            public StringTokenizer tokenizer;
            public InputReader(InputStream stream) {
                reader = new BufferedReader(new InputStreamReader(stream), 32768);
                tokenizer = null;
            }
            public String next() {
                while (tokenizer == null || !tokenizer.hasMoreTokens()) {
                    try {
                        tokenizer = new StringTokenizer(reader.readLine());
                    } catch (IOException e) {
                        throw new RuntimeException(e);
                    }
                }
                return tokenizer.nextToken();
            }
            public int nextInt() {
                return Integer.parseInt(next());
            }
        }
    }
    
  • 相关阅读:
    Linux C编程 GCC的使用
    51nod 1079 中国剩余定理
    51nod 1074 约瑟夫环 V2
    51nod 1073 约瑟夫环
    51nod 1072 威佐夫游戏
    ACM博弈论总结
    51nod 1069 Nim游戏
    2017 ACM-ICPC 亚洲区(南宁赛区)网络赛 The Heaviest Non-decreasing Subsequence Problem
    2017 ACM-ICPC 亚洲区(南宁赛区)网络赛 Overlapping Rectangles
    2017 ACM-ICPC 亚洲区(南宁赛区)网络赛 Minimum Distance in a Star Graph
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/7284018.html
Copyright © 2011-2022 走看看