zoukankan      html  css  js  c++  java
  • Physics Experiment POJ3684

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3849   Accepted: 1361   Special Judge

    Description

    Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

    Simon wants to know where are the N balls after T seconds. Can you help him?

    In this problem, you can assume that the gravity is constant: g = 10 m/s2.

    Input

    The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.
    1≤ N ≤ 100.
    1≤ H ≤ 10000
    1≤ R ≤ 100
    1≤ T ≤ 10000

    Output

    For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

    Sample Input

    2
    1 10 10 100
    2 10 10 100

    Sample Output

    4.95
    4.95 10.20

    Source

     

    #include<iostream>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    const double g = 10.0;
    const int MAX_N=100;
    double y[MAX_N];
    int C,N,H,R,T;
    double calc(int T)
    {
        if(T<0) return H;
        double t = sqrt(2*H/g);
        int k = (int)(T/t);
        if(k%2==0)
        {
            double d = T-k*t;
            return H - g*d*d/2;
        }
        else 
        {
            double d = t-(T-k*t);
            return H - g*d*d/2;
        }
    }
    int main(void)
    {
        cin >> C;
        while(C--)
        {
            cin >> N >> H >> R >> T;
            for(int i=0;i<N;i++)
            {
                y[i] = calc(T-i);
            }
            sort(y,y+N);
            for(int i=0;i<N;i++)
            {
                printf("%.2f%c",y[i]+2*R*i/100.0,i+1==N?'
    ':' '); 
            }
        }
        return 0;
    } 

    重要的是使用ant的碰撞的思路,同时如何处理球的高度的问题。

  • 相关阅读:
    asp.net Forms验证跨域页面不能访问的问题
    JavaScript创建命名空间
    DataTable转换成JSON字符串的函数
    javascript 正确截取单字节和双字节混和字符串的方法
    异常详细信息: 不能通过已删除的行访问该行的信息
    HttpUtility.ParseQueryString直接从字符串URL中提取参数
    支持函数,变量的算术表达式计算(三、加入函数)
    mp3 分类管理工具
    我好累
    电饭煲是如何知道饭已熟了的
  • 原文地址:https://www.cnblogs.com/zuimeiyujianni/p/10031361.html
Copyright © 2011-2022 走看看