zoukankan      html  css  js  c++  java
  • 数组A

    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

    Input

    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

    Output

    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

    Sample Input

    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75

    Sample Output

    $1581.42

    代码:
    #include<stdio.h>
    int main ()
    {
    	int i;
    	double n[12], sum = 0;
    	
    	for(i = 0;i <= 11;i++)
    	{
    		scanf("%lf", &n[i]);
    		sum += n[i];
    	}
    	sum /= 12;
    	
    	printf("$%.2f", sum); 
    	
    	return 0;
     } 
    

      一道很简单的题目,今天因为回家,在路上耽误了很多时间就只写了这一题,明天再肝!

  • 相关阅读:
    泛海精灵软件预发布统计报告 & 反馈
    【scrum】2.23
    VS2010中C#添加图片(资源)
    用XML存储程序的配置
    scrum 2.28
    【Scrum】2.24
    《人月神话》读书心得
    微软R&D喜欢什么人才
    “电脑族”应多做下肢运动
    ASCII表
  • 原文地址:https://www.cnblogs.com/zw431387/p/10235246.html
Copyright © 2011-2022 走看看