zoukankan      html  css  js  c++  java
  • POJ 3071 概率DP

                                                             Football
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3840   Accepted: 1959

    Description

    Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

    Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

    Input

    The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

    Output

    The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

    Sample Input

    2
    0.0 0.1 0.2 0.3
    0.9 0.0 0.4 0.5
    0.8 0.6 0.0 0.6
    0.7 0.5 0.4 0.0
    -1

    Sample Output

    2

    Hint

    In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

    P(2 wins)  P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
    p21p34p23 + p21p43p24
    = 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

    The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

    Source

    题意:给你2^n个队,每次每个相邻的队伍进行比赛,给出你ij比赛i获胜的概率;问你最后哪个队伍获胜概率最大
    题解:dp[i][j]代表前i个轮j获胜了的概率,dp[n][K]K(1,,,N)就是答案
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<queue>
    #include<cmath>
    #include<map>
    using namespace std ;
    typedef long long ll;
    #define mod 1000000007
    #define inf 100000
    inline ll read()
    {
        ll x=0,f=1;char ch=getchar();
        while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
        while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
        return x*f;
    }
    //******************************************************************
    double dp[500][500];
    int n;
    double a[400][440];
    int main()
    {
    
        while(scanf("%d",&n)!=EOF)
        {
            if(n==-1)break;
            for(int j=0;j<(1<<n);j++)
            for(int i=0;i<(1<<n);i++)
            {
                scanf("%lf",&a[j][i]);
            }
            memset(dp,0,sizeof(dp));
            for(int i=0;i<(1<<n);i++)
            {
                dp[0][i]=1;
            }
            for(int i=1;i<=n;i++)
            {
                for(int j=0;j<(1<<n);j++)
                {
                    int tmp=(1<<(i-1));
                    int t=j/tmp;
                    t=t^1;
                    for(int k=t*tmp;k<(t+1)*(tmp);k++)
                    {
                        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*a[j][k];
                    }
                }
            }
            int ans;
            double maxx=-1.0;
            for(int i=0;i<(1<<n);i++)
            {
                if(dp[n][i]>maxx)
                {
                    ans=i;
                    maxx=dp[n][i];
                }
            }
            cout<<ans+1<<endl;
        }
        return 0;
    }
    代码
  • 相关阅读:
    移动Web开发规范概述
    hibernate 多对多
    hibernate 1 对1
    hibernate 双向1对多
    Hibernate 单项多对1
    Hibernate Session 4种对象状态
    Hibernate Session缓存
    Hibernaate 详解
    Hibernate学习 (一)
    Struts拦截器Interceptor
  • 原文地址:https://www.cnblogs.com/zxhl/p/4781426.html
Copyright © 2011-2022 走看看