zoukankan      html  css  js  c++  java
  • AtCoder Beginner Contest 064 D

    AtCoder Beginner Contest 064 D - Insertion

    Problem Statement

    You are given a string S of length N consisting of ( and ). Your task is to insert some number of ( and ) into S to obtain a correct bracket sequence.
    Here, a correct bracket sequence is defined as follows:

    • () is a correct bracket sequence.
    • If X is a correct bracket sequence, the concatenation of (X and ) in this order is also a correct bracket sequence.
    • If X and Y are correct bracket sequences, the concatenation of X and Y in this order is also a correct bracket sequence.
    • Every correct bracket sequence can be derived from the rules above.

    Find the shortest correct bracket sequence that can be obtained. If there is more than one such sequence, find the lexicographically smallest one.

    Constraints

    • The length of S is N.
    • 1≤N≤100
    • S consists of ( and ).

    Input

    Input is given from Standard Input in the following format:

    N
    S
    

    Output

    Print the lexicographically smallest string among the shortest correct bracket sequences that can be obtained by inserting some number of ( and ) into S.


    Sample Input 1

    3
    ())
    

    Sample Output 1

    (())
    

    Sample Input 2

    6
    )))())
    

    Sample Output 2

    (((()))())
    

    Sample Input 3

    8
    ))))((((
    

    Sample Output 3

    (((())))(((())))

    题意就是给定长度的字符串加括号,使得括号相匹配。

    不会。栈模拟半天也不知道怎么弄。看了别人的代码惊为天人!

    一言以蔽之就是,先找出已经配对好的不管;剩下有多少个'('字符串后面就补多少个')'、有多少个')'字符串前面就补多少个'('。

    直接从代码中领悟吧:

    #include<iostream>
    #include<string>
    using namespace std;
    
    int main()
    {
        int n;
        string s;
        cin >> n;
        cin >> s;
        int totl = 0, totr = 0;
        for (int i = 0; i < s.length(); i++) {
            if (s[i] == '(') totl++;
            else
            {
                if (totl > 0) totl--;
                else totr++;
            }
        }
        for (int i = 0; i < totl; i++) s = s + ')';
        for (int i = 0; i < totr; i++) s = '(' + s;
        cout << s << endl;
        return 0;
    }
  • 相关阅读:
    【bzoj2669】[cqoi2012]局部极小值 容斥原理+状压dp
    默默的等式
    P3403 跳楼机
    作物
    【bzoj3174】[Tjoi2013]拯救小矮人
    【bzoj4976】宝石镶嵌
    BZOJ2121-字符串游戏
    mzf的考验
    牛客网round1
    jloi2015
  • 原文地址:https://www.cnblogs.com/zxhyxiao/p/6980176.html
Copyright © 2011-2022 走看看