zoukankan      html  css  js  c++  java
  • poj 2184 01背包变形【背包dp】

    POJ 2184

    Cow Exhibition
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 14657   Accepted: 5950

    Description

    "Fat and docile, big and dumb, they look so stupid, they aren't much
    fun..."
    - Cows with Guns by Dana Lyons

    The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

    Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

    Input

    * Line 1: A single integer N, the number of cows

    * Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

    Output

    * Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

    Sample Input

    5
    -5 7
    8 -6
    6 -3
    2 1
    -8 -5
    

    Sample Output

    8
    

    Hint

    OUTPUT DETAILS:

    Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
    = 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
    of TS+TF to 10, but the new value of TF would be negative, so it is not
    allowed.

    题意:给定N头牛的smart值和fun值,求选出若干头牛使得smart值加fun值之和最大,且两值分别之和不能小于零。

    题解:每一头牛都是选或不选,做法应该是01背包dp。但是空间容量没有,有两个值s[i],f[i]。把其中一个值作为背包容量,另一个作为价值。定义i表示前k头牛的智力总和,dp[i]存储前k头牛智力总和为i时的幽默值总和的最大值。由于s[i]可能为负,且s[i]代表“空间”,所以s[i]为负时要像完全背包一样正序循环。理由见参考博客。且根据数据范围易知∑s[i]属于[-1e5,1e5],因为“空间”有的部分,所以可以整体平移1e5,使得“空间”大小非负,那么此时原来的0点就变成了1e5,空间容量最大就为2e5。这样求得dp[i]表示幽默值总和,i表示智力总和,又因为有平移。所以最后结果为ans=max(dp[i]+i-1e5),dp[i]>0.

    下面代码C++编译器能过,G++ runtime error ,我还特意把数组开大了,不是很懂。。。

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int maxn=1e5;
    int dp[2*maxn+5000];
    int s[105],f[105];
    
    int main()
    {
        int N;
        cin>>N;
        for(int i=0;i<=2*maxn+1020;i++) dp[i]=-1e8;
        dp[maxn]=0;
        for(int i=1;i<=N;i++) cin>>s[i]>>f[i];
        for(int i=1;i<=N;i++){
            if(s[i]>=0){
                for(int j=maxn*2;j>=s[i];j--)
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
            }
            else
            {
                for(int j=s[i];j<=maxn*2;j++)
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
            }
        }
        int ans=0;
        for(int i=maxn;i<=2*maxn;i++)
            if(dp[i]>0)
                ans=max(ans,dp[i]+i-maxn);
        cout<<ans<<endl;
        return 0;
    }

    这份仿照别人的写的:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    #include<vector>
    using namespace std;
    #define S 100000
    #define M 200000
    #define INF 0x3f3f3f3f
    int dp[M+5];
    
    int main()
    {
        int n,m;
        int a[105],b[105];
        while(cin>>n)
        {
            for(int i=0;i<n;i++) cin>>a[i]>>b[i];
            memset(dp,-INF,sizeof(dp));
            dp[S]=0;
            for(int i=0;i<n;i++)
            {
                if(a[i]>0){
                    for(int j=M;j>=a[i];j--)
                        //if(dp[j-a[i]]>-INF)
                        dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
                }
                else
                {
                    for(int j=0;j-a[i]<=M;j++)
                        //if(dp[j-a[i]]>-INF)
                        dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
                }
            }
            int ans=0;
            for(int i=S;i<=M;i++)
                if(dp[i]>=0)
                    ans=max(ans,dp[i]+i-S);
            cout<<ans<<endl;
        }
        return 0;
    }

    参考博客(感谢博主们):

    【1】:https://www.cnblogs.com/Findxiaoxun/p/3398075.html

    【2】:https://www.cnblogs.com/pshw/p/5031109.html

    【3】:http://blog.csdn.net/keysona/article/details/45751903

  • 相关阅读:
    Mime Types
    对MySQL DELETE语法的详细解析
    创建MySQL存储过程示例
    Python安装
    python学习之matplotlib实战
    python学习之numpy实战
    SQLserver建表规则
    机器学习之BP神经网络
    机器学习之决策树算法
    Spring学习总结
  • 原文地址:https://www.cnblogs.com/zxhyxiao/p/8414348.html
Copyright © 2011-2022 走看看