zoukankan      html  css  js  c++  java
  • NBUT[1220] SPY

    问题描述
    The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’s confidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?
    A:the list contains that will come to the NationX’s frontier.
    B:the list contains spies that will be sent by Nation Y.
    C:the list contains spies that were sent to NationY before.
    输入
    There are several test cases.
    Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.
    The second part contains A strings, the name list of that will come into the frontier.
    The second part contains B strings, the name list of that are sent by NationY.
    The second part contains C strings, the name list of the “dual_spy”.
    There will be a blank line after each test case.
    There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.
    输出
    Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.
    样例输入
    8 4 3
    Zhao Qian Sun Li Zhou Wu Zheng Wang
    Zhao Qian Sun Li
    Zhao Zhou Zheng
    2 2 2
    Zhao Qian
    Zhao Qian
    Zhao Qian
    样例输出
    Qian Sun Li
    No enemy spy

    题意:给出A,B,C,代表下面三行的第一行有A个名字,第二行有B个名字,第三行有C个名字,先从第一行中去除第三行的名字,再看第一行的数据中包含第二行的1数据嘛,有的话输出,没有就输出“ No enemy spy”;
    注意:最后一个名字没空格。

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string>
    #include<map>
    using namespace std;
    map<string,int>m;
    string b[100],s,c[100];
    int main()
    {
        int A,B,C;
        while(cin>>A>>B>>C)
        {
            int flag=0,cou=0;
            m.clear();
            for(int i=0; i<A; i++)
            {
                cin>>s;
                m[s]=1;
            }
            for(int i=0; i<B; i++)
            {
                cin>>s;
                b[i]=s;
            }
            for(int i=0; i<C; i++)
            {
                cin>>s;
                m[s]=0;
            }
            for(int i=0; i<B; i++)
            {
                if(m[b[i]]==1)
                {
                    flag=1;
                    c[cou++]=b[i];
                }
            }
            //cout<<cou<<endl;
            for(int i=0;i<cou;i++)
            {
                if(i==(cou-1))
                    cout<<c[i];
                else
                    cout<<c[i]<<" ";
            }
            if(flag==0)
                cout<<"No enemy spy";
            cout<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    【项目一 · 直播】 ☞ 3. 推流直播
    【项目一 · 直播】 ☞ 2. 拉流直播
    【Objective-C 篇】 ☞ 10. 代理设计模式
    高精度模板
    csp每日习题
    pat乙级每日习题
    dp-LIS LCS 模型
    线性dp
    归并排序应用-求逆序对数量
    dp-位移模型(数字三角形演变)
  • 原文地址:https://www.cnblogs.com/zxy160/p/7215125.html
Copyright © 2011-2022 走看看