zoukankan      html  css  js  c++  java
  • 序列合并 优先队列

    题目描述

    有两个长度都是N的序列A和B,在A和B中各取一个数相加可以得到N2N^2N2个和,求这N2N^2N2个和中最小的N个。

    输入输出格式

    输入格式:

    第一行一个正整数N;

    第二行N个整数AiA_iAi, 满足Ai≤Ai+1A_ile A_{i+1}AiAi+1Ai≤109A_ile 10^9Ai109;

    第三行N个整数BiB_iBi, 满足Bi≤Bi+1B_ile B_{i+1}BiBi+1Bi≤109B_ile 10^9Bi109.

    【数据规模】

    对于50%的数据中,满足1<=N<=1000;

    对于100%的数据中,满足1<=N<=100000。

    输出格式:

    输出仅一行,包含N个整数,从小到大输出这N个最小的和,相邻数字之间用空格隔开。

    输入输出样例

    输入样例#1: 复制
    3
    2 6 6
    1 4 8
    输出样例#1: 复制
    3 6 7

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<map>
    #include<set>
    #include<vector>
    #include<queue>
    #include<bitset>
    #include<ctime>
    #include<deque>
    #include<stack>
    #include<functional>
    #include<sstream>
    //#include<cctype>
    //#pragma GCC optimize(2)
    using namespace std;
    #define maxn 700005
    #define inf 0x7fffffff
    //#define INF 1e18
    #define rdint(x) scanf("%d",&x)
    #define rdllt(x) scanf("%lld",&x)
    #define rdult(x) scanf("%lu",&x)
    #define rdlf(x) scanf("%lf",&x)
    #define rdstr(x) scanf("%s",x)
    typedef long long  ll;
    typedef unsigned long long ull;
    typedef unsigned int U;
    #define ms(x) memset((x),0,sizeof(x))
    const long long int mod = 1e9 + 7;
    #define Mod 1000000000
    #define sq(x) (x)*(x)
    #define eps 1e-3
    typedef pair<int, int> pii;
    #define pi acos(-1.0)
    //const int N = 1005;
    #define REP(i,n) for(int i=0;i<(n);i++)
    typedef pair<int, int> pii;
    inline ll rd() {
    	ll x = 0;
    	char c = getchar();
    	bool f = false;
    	while (!isdigit(c)) {
    		if (c == '-') f = true;
    		c = getchar();
    	}
    	while (isdigit(c)) {
    		x = (x << 1) + (x << 3) + (c ^ 48);
    		c = getchar();
    	}
    	return f ? -x : x;
    }
    
    ll gcd(ll a, ll b) {
    	return b == 0 ? a : gcd(b, a%b);
    }
    int sqr(int x) { return x * x; }
    
    
    /*ll ans;
    ll exgcd(ll a, ll b, ll &x, ll &y) {
    	if (!b) {
    		x = 1; y = 0; return a;
    	}
    	ans = exgcd(b, a%b, x, y);
    	ll t = x; x = y; y = t - a / b * y;
    	return ans;
    }
    */
    
    int  n;
    int a[maxn], b[maxn];
    map<pii, int>mp;
    struct node {
    	int x, y;
    	bool operator<(const node&t)const {
    		if (a[x] + b[y] < a[t.x] + b[t.y])return false;
    		return true;
    	}
    	node(int X, int Y) { x = X, y = Y; }
    };
    priority_queue<node>q;
    
    int main() {
    	//ios::sync_with_stdio(0);
    	cin >> n;
    	for (int i = 1; i <= n; i++)rdint(a[i]);
    	for (int j = 1; j <= n; j++)rdint(b[j]);
    	q.push(node(1, 1));
    	for (int i = 1; i <= n; i++) {
    		while (mp[make_pair(q.top().x, q.top().y)])q.pop();
    		int tmpx = q.top().x, tmpy = q.top().y;
    		cout << a[tmpx] + b[tmpy] << ' ';
    		mp[make_pair(tmpx, tmpy)] = 1;
    		q.push(node(tmpx + 1, tmpy)); q.push(node(tmpx, tmpy + 1));
    	}
    	
    	return 0;
    }
    
    EPFL - Fighting
  • 相关阅读:
    libusb简介
    STM8S和STM8L调试串口中断的注意点
    QT 5.1.1 for Android 开发环境搭建与配置【Windows 7】
    【Luogu3806】点分治(点分治)
    NOIP2017+停课总结
    【BZOJ2301】【HAOI2011】Problem B(莫比乌斯反演)
    【Luogu3455】【POI2007】ZAP-Queries(莫比乌斯反演)
    【HDU1695】GCD(莫比乌斯反演)
    【BZOJ2816】【ZJOI2012】网络(Link-Cut Tree)
    莫比乌斯反演
  • 原文地址:https://www.cnblogs.com/zxyqzy/p/10262026.html
Copyright © 2011-2022 走看看