zoukankan      html  css  js  c++  java
  • 字串变换 bfs + 字符串

    题目描述

    已知有两个字串A,BA,BA,B及一组字串变换的规则(至多666个规则):

    A1A_1A1 ->B1 B_1B1

    A2A_2A2 -> B2B_2B2

    规则的含义为:在 AAA中的子串 A1A_1A1 可以变换为B1 B_1B1A2A_2A2 可以变换为 B2B_2B2 …。

    例如:AAA='abcdabcdabcd'BBB='xyzxyzxyz'

    变换规则为:

    abcabcabc’->‘xuxuxu’‘ududud’->‘yyy’‘yyy’->‘yzyzyz’

    则此时,AAA可以经过一系列的变换变为BBB,其变换的过程为:

    abcdabcdabcd’->‘xudxudxud’->‘xyxyxy’->‘xyzxyzxyz’

    共进行了333次变换,使得AAA变换为BBB。

    输入输出格式

    输入格式:

    输入格式如下:

    AAA BBB
    A1A_1A1 B1B_1B1
    A2A_2A2 B2B_2B2 |-> 变换规则

    ... ... /

    所有字符串长度的上限为202020。

    输出格式:

    输出至屏幕。格式如下:

    若在101010步(包含101010步)以内能将AAA变换为BBB,则输出最少的变换步数;否则输出"NO ANSWER!"

    输入输出样例

    输入样例#1: 复制
    abcd xyz
    abc xu
    ud y
    y yz
    
    输出样例#1: 复制
    3
    
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<map>
    #include<set>
    #include<vector>
    #include<queue>
    #include<bitset>
    #include<ctime>
    #include<deque>
    #include<stack>
    #include<functional>
    #include<sstream>
    //#include<cctype>
    //#pragma GCC optimize(2)
    using namespace std;
    #define maxn 100005
    #define inf 0x7fffffff
    //#define INF 1e18
    #define rdint(x) scanf("%d",&x)
    #define rdllt(x) scanf("%lld",&x)
    #define rdult(x) scanf("%lu",&x)
    #define rdlf(x) scanf("%lf",&x)
    #define rdstr(x) scanf("%s",x)
    typedef long long  ll;
    typedef unsigned long long ull;
    typedef unsigned int U;
    #define ms(x) memset((x),0,sizeof(x))
    const long long int mod = 1e9 + 7;
    #define Mod 1000000000
    #define sq(x) (x)*(x)
    #define eps 1e-4
    typedef pair<int, int> pii;
    #define pi acos(-1.0)
    //const int N = 1005;
    #define REP(i,n) for(int i=0;i<(n);i++)
    typedef pair<int, int> pii;
    inline ll rd() {
    	ll x = 0;
    	char c = getchar();
    	bool f = false;
    	while (!isdigit(c)) {
    		if (c == '-') f = true;
    		c = getchar();
    	}
    	while (isdigit(c)) {
    		x = (x << 1) + (x << 3) + (c ^ 48);
    		c = getchar();
    	}
    	return f ? -x : x;
    }
    
    ll gcd(ll a, ll b) {
    	return b == 0 ? a : gcd(b, a%b);
    }
    int sqr(int x) { return x * x; }
    
    
    /*ll ans;
    ll exgcd(ll a, ll b, ll &x, ll &y) {
    	if (!b) {
    		x = 1; y = 0; return a;
    	}
    	ans = exgcd(b, a%b, x, y);
    	ll t = x; x = y; y = t - a / b * y;
    	return ans;
    }
    */
    
    struct node {
    	string str;
    	int stp;
    };
    string a, b;
    string orign[maxn];
    string trans[maxn];
    int n, ans;
    map<string, int>mp;
    string tran(const string &str, int i, int j) {
    	string ans = "";
    	if (i + orign[j].length() > str.length())return ans;
    	for (int k = 0; k < orign[j].length(); k++) {
    		if (str[i + k] != orign[j][k])return ans;
    	}
    	ans = str.substr(0, i);
    	ans += trans[j];
    	ans += str.substr(i + orign[j].length());
    	return ans;
    }
    void bfs() {
    	queue<node>q;
    	node s; s.str = a; s.stp = 0; q.push(s);
    	while (!q.empty()) {
    		node u = q.front(); q.pop();
    		string tmp;
    		if (mp.count(u.str))continue;
    		if (u.str == b) {
    			ans = u.stp; break;
    		}
    		mp[u.str] = 1;
    		for (int i = 0; i < u.str.length(); i++) {
    			for (int j = 0; j < n; j++) {
    				tmp = tran(u.str, i, j);
    				if (tmp != "") {
    					node v; v.str = tmp; v.stp = u.stp + 1;
    					q.push(v);
    				}
    			}
    		}
    	}
    	if (ans > 10 || ans == 0)cout << "NO ANSWER!" << endl;
    	else cout << ans << endl;
    }
    
    
    int main() {
    	ios::sync_with_stdio(0);
    	cin >> a >> b;
    	while (cin >> orign[n] >> trans[n])n++;
    	bfs();
    	return 0;
    }
    
    EPFL - Fighting
  • 相关阅读:
    Codeforces Round #343 (Div. 2) B. Far Relative’s Problem 暴力
    Codeforces Round #343 (Div. 2) A. Far Relative’s Birthday Cake 水题
    Educational Codeforces Round 8 F. Bear and Fair Set 最大流
    Educational Codeforces Round 8 E. Zbazi in Zeydabad 树状数组
    Educational Codeforces Round 8 D. Magic Numbers 数位DP
    Educational Codeforces Round 8 C. Bear and String Distance 贪心
    Educational Codeforces Round 8 B. New Skateboard 暴力
    Educational Codeforces Round 8 A. Tennis Tournament 暴力
    BZOJ 4032: [HEOI2015]最短不公共子串 后缀自动机 暴力
    BZOJ 4031: [HEOI2015]小Z的房间 高斯消元 MartixTree定理 辗转相除法
  • 原文地址:https://www.cnblogs.com/zxyqzy/p/10274072.html
Copyright © 2011-2022 走看看