zoukankan      html  css  js  c++  java
  • POJ1797:Heavy Transportation(并查集)

    http://poj.org/problem?id=1797

    Description

    Background
    Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
    Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

    Problem
    You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

    Input

    The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

    Sample Input

    1
    3 3
    1 2 3
    1 3 4
    2 3 5
    

    Sample Output

    Scenario #1:
    4
    

    题意分析:

    给出所有路的承受能力,问从1到n的所有路中最高的最低承受能力是多少。

    解题思路:

    先把道路的承受能力从大到小排序,一一并入,直到1和n连通,输出此时的道路承受能力。

    #include <stdio.h>
    #include <algorithm>
    #define N 1020
    using namespace std;
    struct edge{
    	int u; 
    	int v;
    	int w;
    }e[N*N];
    int f[N];
    int cmp(edge a, edge b)
    {
    	return a.w > b.w;
    }
    int getf(int v)
    {
    	if (f[v] == v)
    		return v;
    	else
    	{
    		f[v] = getf(f[v]);
    		return f[v];
    	}
    }
    int merge(int u, int v)
    {
    	int t1, t2;
    	t1 = getf(u);
    	t2 = getf(v);
    	if (t1 != t2)
    	{
    		f[t1] = t2;
    		return 1;
    	}
    	return 0;
    }
    int main()
    {
    	int t, T, i, j, n, m, sum;
    	scanf("%d", &t);
    	T = 0;
    	while (t--)
    	{
    		scanf("%d%d", &n, &m);
    		for (i = 0; i < m; i++)
    			scanf("%d%d%d", &e[i].u, &e[i].v, &e[i].w);
    		for (i = 1; i <= n; i++)
    			f[i] = i;
    		sort(e, e + m, cmp);
    		sum = 0;
    		for (i = 0; i < m; i++)
    		{
    			sum += merge(e[i].u, e[i].v);
    			if (getf(1)==getf(n))
    				break;
    		}
    		printf("Scenario #%d:
    %d
    ", ++T, e[i].w);
    	}
    	return 0;
    }
  • 相关阅读:
    web http协议
    swoole udp
    swoole线程和进程
    SVN中trunk,branches,tags用法详解
    mysql外键使用和事物使用
    xml
    dedecms开启报错
    Django CBV方法装饰器
    Django Cookie和Session
    ORM基础5
  • 原文地址:https://www.cnblogs.com/zyq1758043090/p/11852600.html
Copyright © 2011-2022 走看看