zoukankan      html  css  js  c++  java
  • hdu 1003 Max sum(简单DP)

    Max Sum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Problem Description

    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

    Sample Input

    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

    Sample Output

    Case 1: 14 1 4 Case 2: 7 1 6

    题意:求最大连续和,并输出该连续和的起始、结尾位置

    #include <iostream>
    #include <algorithm>
    using namespace std;
    const int maxn=100010;
    
    int a,b,dp[maxn],pre[maxn];
    
    int main()
    {
        int m,n,T,cas;
        cin>>T;
        for(cas=1;cas<=T;cas++)
        {
            cout<<"Case "<<cas<<':'<<endl;
            cin>>n;
            cin>>dp[1];
            m=pre[1]=1;
    
            for(int i=2; i<=n; i++ )
            {
                cin>>a;
                if(dp[i-1]>=0)//注意这里是大于'等于'0;
                {
                    dp[i]=a+dp[i-1];
                    pre[i]=pre[i-1];
                }
                else
                    dp[i]=a,pre[i]=i;
                if( dp[i] > dp[m] )
                        m=i;//m保存当前最大连续和的下标
            }
    
            cout<<dp[m]<<' '<<pre[m]<<' '<<m<<endl;
            if(cas!=T) cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Django REST framework的解析器与渲染器
    python基础之 数据格式化
    REST framework 之 分页
    Django REST framework 之 认证 权限 限制
    DjangoRestFrameWork 版本控制
    DjangoRESTFrameWork中的视图
    浏览器跨域问题
    初识REST
    vue之生命周期
    vue组件
  • 原文地址:https://www.cnblogs.com/zyx1314/p/3538929.html
Copyright © 2011-2022 走看看