zoukankan      html  css  js  c++  java
  • hdu 1258

    Sum It Up

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6448    Accepted Submission(s): 3365


    Problem Description
    Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
     
    Input
    The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
     
    Output
    For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
     
    Sample Input
    4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
     
    Sample Output
    Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
     自己拿set判的重,代码还有瑕疵,数据太水水过。哎
    这道题也是每次两种决策,加上这个数或者不加,判重类似于全排列的判重方式。

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int num,n,pos;
    int a[15],b[15];
    bool judge = false;
    void output(int depth)
    {
    for(int i =0 ;i< depth; ++i)
    if(!i) printf("%d",b[i]);
    else printf("+%d",b[i]);
    printf(" ");
    }
    void dfs(int depth,int sum,int pos)                                //每一位数字只有两种可能(加/不加),pos表示当前进行到了哪一位,depth表示b里保存的数字数量便于打印
    {
    if(sum == num) {judge = true;output(depth); return;}
    if(sum>num) return;// 超出了 终止递归
    if(pos>=n) return; //选择的数的位置超出数据范围
    b[depth] = a[pos];
    dfs(depth+1,sum+a[pos],pos+1);
    while(pos+1<n&&a[pos] == a[pos+1]) pos++;//关键  判重
    dfs(depth,sum,pos+1);


    }
    int main()
    {

    while(scanf("%d%d",&num,&n) && num){
    printf("Sums of %d: ",num);
    for(int i = 0; i<n; ++i) scanf("%d",&a[i]);
    judge = false;
    dfs(0,0,0);

    if(judge == false) printf("NONE ");
    }
    return 0;
    }

  • 相关阅读:
    jQuery Dialog and timepicker显示层的问题
    js、PHP将分数字符串转换为小数
    jqgrid动态显示/隐藏某一列
    Oracle查询每天固定时间段的数据
    Python安装pandas
    Python version 2.7 required, which was not found in the registry
    python刷剑指offer(1-20)(一刷)
    图像预处理(含计算机视觉概述)
    案例分析
    (七)目标检测算法之SSD
  • 原文地址:https://www.cnblogs.com/zzqc/p/6528139.html
Copyright © 2011-2022 走看看