zoukankan      html  css  js  c++  java
  • HDU 1969 精度二分

    Pie

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12394    Accepted Submission(s): 4371


    Problem Description
    My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

    My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

    What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
     
    Input
    One line with a positive integer: the number of test cases. Then for each test case:
    ---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
    ---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
     
    Output
    For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
     
    Sample Input
    3
    3 3
    4 3 3
    1 24
    5
    10 5
    1 4 2 3 4 5 6 5 4 2
     
    Sample Output
    25.1327 3.1416 50.2655
     
    Source
     
    二分每块pie的大小即可,主要是精度问题,由于精确到1e-4所以while(r-l>0.0001)即可,但是里面对于r的操作不写精度+-得话就能A,如果写必须注意精度了开到1e-7才A   (⊙﹏⊙)b
    #include<bits/stdc++.h>
    using namespace std;
    #define PI acos(-1.0)
    double a[10005],F,N;
    bool can(double s)
    {
      int sum=0,i;
      for(i=1;i<=N;++i) sum+=floor(a[i]/s);
      return sum>=F;
    }
    int main()
    {
        int i,j,k,t;
        cin>>t;
        while(t--){
            cin>>N>>F;
            F++;
            for(i=1;i<=N;++i) {
                    cin>>a[i];
                    a[i]=a[i]*a[i]*PI;
            }
            double l=0,r=10000*10000*PI,mid;
            while(r-l>0.00001){
                mid=r-(r-l)/2;
                if(can(mid)){
                    l=mid;
                }
                else{
                    r=mid-0.0000001;
                }
            }
            printf("%.4f ",l);
        }
        return 0;
    }

     
  • 相关阅读:
    Python爬虫初识
    使用Hexo和Github Pages快速搭建个人博客
    jQuery Grid入门指南(2)
    jQuery Grid入门指南(1)
    实习小结(五)--- SSM框架搭建(Maven项目)
    win10开机就占用了50%内存,win10越用越卡
    项目导入The type java.lang.String cannot be resolved. It is indirectly referenced from required is indirectly referenced fr
    eclipse中src以文件夹形式展示,没有以package包形式展示
    Unexpected exception parsing XML document from file [F:meideerpinterfacewebWEB-INFclassesspringspring.xml]; nested exception is java.lang.UnsupportedClassVersionError: Bad version number in .cl
    oracle数据导入dmp
  • 原文地址:https://www.cnblogs.com/zzqc/p/7118615.html
Copyright © 2011-2022 走看看