zoukankan      html  css  js  c++  java
  • The Longest Straight(FZUoj2216)

     Problem 2216 The Longest Straight

    Accept: 82    Submit: 203
    Time Limit: 1000 mSec    Memory Limit : 32768 KB

     Problem Description

    ZB is playing a card game where the goal is to make straights. Each card in the deck has a number between 1 and M(including 1 and M). A straight is a sequence of cards with consecutive values. Values do not wrap around, so 1 does not come after M. In addition to regular cards, the deck also contains jokers. Each joker can be used as any valid number (between 1 and M, including 1 and M).

    You will be given N integers card[1] .. card[n] referring to the cards in your hand. Jokers are represented by zeros, and other cards are represented by their values. ZB wants to know the number of cards in the longest straight that can be formed using one or more cards from his hand.

     Input

    The first line contains an integer T, meaning the number of the cases.

    For each test case:

    The first line there are two integers N and M in the first line (1 <= N, M <= 100000), and the second line contains N integers card[i] (0 <= card[i] <= M).

     Output

    For each test case, output a single integer in a line -- the longest straight ZB can get.

     Sample Input

    2

    7 11

    0 6 5 3 0 10 11

    8 1000

    100 100 100 101 100 99 97 103

     Sample Output

    5

    3

     Source

    第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

     思路:尺取法,先将哪些点是否出现过标记,并记录0的个数,然后再前缀数组统计1到M中的未出现的数字,

    在用尺取法跑一遍区间取最长就可以了。

    #include<stdio.h>
    #include<algorithm>
    #include<iostream>
    #include<stdlib.h>
    #include<string.h>
    using namespace std;
    int aa[100005];
    int bb[100005];
    int main(void)
    {
        int n,i,j,k,p,q;
        scanf("%d",&k);
        while(k--)
        {
            memset(aa,0,sizeof(aa));
            memset(bb,0,sizeof(bb));
            scanf("%d %d",&p,&q);int ma=0;
            for(i=0; i<p; i++)
            {
                scanf("%d",&n);
                aa[n]++;
                if(ma<n)
                {
                    ma=n;
                }
            }
            int cnt=aa[0];
            bb[0]=0;ma=min(ma+cnt,q);
            for(i=1; i<=q; i++)
            {
                if(!aa[i])
                {
                    bb[i]=bb[i-1]+1;
                }
                else
                {
                    bb[i]=bb[i-1];
                }

            }
            int ll=1;
            int rr=1;
            int maxx=0;

            while(rr<=ma&&ll<=rr+1)
            {
                while(bb[rr]-bb[ll-1]<=cnt&&rr<=ma)
                {
                    rr++;
                }
                maxx=max(maxx,(rr-ll));
                ll++;
            }
            printf("%d ",maxx);
        }
        return 0;}

    } 

    油!油!you@
  • 相关阅读:
    Joshua Bloch错了? ——适当改变你的Builder模式实现
    集成基于OAuth协议的单点登陆
    集成基于CAS协议的单点登陆
    数据库设计中的Soft Delete模式
    完成C++不能做到的事
    ExtJS in Review
    DTO – 服务实现中的核心数据
    保存好你的密码 —— 从芝麻金融被攻破说起
    WPF
    C# 反编译防范
  • 原文地址:https://www.cnblogs.com/zzuli2sjy/p/5181374.html
Copyright © 2011-2022 走看看