zoukankan      html  css  js  c++  java
  • The Suspects (并查集)

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    并查集。不过和畅通工程的题目有一点不一样就是不是总是输入两个的,对于两个以上的先用第一个数和后面的数去操作就好,然后注意最后计算count不是等于0 而是f[0]
    #include<iostream>
    using namespace std;
    #define maxn 30005
    int n,m,f[maxn];
    void getf(){
        for(int i=0;i<n;i++)
            f[i]=i;
    }
    int find(int x){
        if(f[x]==x)
            return x;
        else{
            f[x]=find(f[x]);
            return f[x];
        }
    }
    void check(int a,int b){
        int x=find(a);
        int y=find(b);
        if(x!=y){
            f[y]=x;
        }
        return;
    }
    int main()
    {
        int x;
        int first,next;
        while(cin>>n>>m){
            int count=0;
            if(n==0&&m==0)
                break;
            getf();
            while(m--){
                cin>>x;
                cin>>first;
                for(int i=1;i<x;i++){
                    cin>>next;
                    check(first,next);
                }
            }
            for(int i=0;i<n;i++){
                if(find(i)==f[0]){
                    count++;
                }
            }
            cout<<count<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    《Apache Velocity用户指南》官方文档
    Mockito教程
    GitHub访问速度慢的解决方法
    使用log4jdbc记录SQL信息
    分环境部署SpringBoot日志logback-spring.xml
    SpringBoot入门之spring-boot-maven-plugin
    swagger报No operations defined in spec!
    delphi 时间
    DELPHI常用类型及定义单元
    delphi 多线程编程
  • 原文地址:https://www.cnblogs.com/zzzying/p/7295881.html
Copyright © 2011-2022 走看看