zoukankan      html  css  js  c++  java
  • poj1836——dp,最长上升子序列(lis)

    poj1836——dp,最长上升子序列(lis)

    Alignment
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 13767   Accepted: 4450

    Description

    In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

    Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

    Input

    On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

    There are some restrictions: 
    • 2 <= n <= 1000 
    • the height are floating numbers from the interval [0.5, 2.5] 

    Output

    The only line of output will contain the number of the soldiers who have to get out of the line.

    Sample Input

    8
    1.86 1.86 1.30621 2 1.4 1 1.97 2.2
    

    Sample Output

    4

    题意:使队列中出列部分士兵,使剩余士兵身高先单增后单减(单调部分不可相等),求最少的出列士兵数量
    思路:求两次lis(最长上升子序列),再遍历得出答案;lis:dp(i)=max{dp(j)+1,dp(i)},初始化dp[]={1};
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<cstdio>
    
    using namespace std;
    
    const int maxn=1000100;
    int n;
    double h[maxn];
    int dp1[maxn],dp2[maxn];
    
    int main()
    {
        while(cin>>n){
            for(int i=0;i<n;i++){
                cin>>h[i];
                dp1[i]=dp2[i]=1;
            }
            for(int i=0;i<n;i++){  //求最长上升子序列(lis)
                for(int j=0;j<i;j++){
                    if(h[j]<h[i]) dp1[i]=max(dp1[j]+1,dp1[i]);
                }
            }
            for(int i=n-1;i>=0;i--){
                for(int j=n-1;j>i;j--){
                    if(h[j]<h[i]) dp2[i]=max(dp2[j]+1,dp2[i]);
                }
            }
            int ans=0;
            for(int i=0;i<n-1;i++){
                for(int j=i+1;j<n;j++){
                    if(dp1[i]+dp2[j]>ans) ans=dp1[i]+dp2[j];
                }
            }
            cout<<n-ans<<endl;
        }
        return 0;
    }
    View Code
    当然lis有nlogn的做法

    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    洛谷 P2330 [SCOI2005]繁忙的都市
    2016-2017 ACM-ICPC, Asia Tsukuba Regional Contest D Hidden Anagrams
    HDU1792A New Change Problem(GCD规律推导)
    HDU1222Wolf and Rabbit(GCD思维)
    poj2635The Embarrassed Cryptographer(同余膜定理)
    poj3270Cow Sorting(置换+贪心)
    计数排序(O(n+k)的排序算法,空间换时间)
    POJ1222EXTENDED LIGHTS OUT(高斯消元)
    BZOJ 2038: [2009国家集训队]小Z的袜子(hose) (莫队算法)
    2301: [HAOI2011]Problem b ( 分块+莫比乌斯反演+容斥)
  • 原文地址:https://www.cnblogs.com/--560/p/4352315.html
Copyright © 2011-2022 走看看