zoukankan      html  css  js  c++  java
  • hdu-1022-栈

    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 51329    Accepted Submission(s): 19314


    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    Sample Input
    3 123 321 3 123 312
     
    Sample Output
    Yes. in in in out out out FINISH No. FINISH
    Hint
    Hint
    For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
     
     题意:给出一个n,有两个序列,每个序列里有n个元素,问能不能利用栈把第一个序列变成第二个序列。 分析:栈的简单应用,注意每次都要把栈清空
     
    #include<iostream>
    #include<string.h>
    #include<queue>
    #include<stack>
    using namespace std;
    stack<char>a;
    int main()
    {
      int n;
      int vis[10];
      char s[10],ss[10];
      while(cin>>n>>s>>ss&&n)
      {
        int j=0,k=0;
        for(int i=0;i<n;i++)
        {
          a.push(s[i]);
          vis[k++]=1;
          while(!a.empty()&&a.top()==ss[j])
          {
            vis[k++]=0;
            a.pop();
            j++;
          }
        }
        if(a.empty())
        {
          cout<<"Yes."<<endl;
          for(int i=0;i<k;i++)
          {
            if(vis[i]==1)
            cout<<"in"<<endl;
          else
            cout<<"out"<<endl;
          }
          cout<<"FINISH"<<endl;
        }
        else
        {
          cout<<"No."<<endl;
          cout<<"FINISH"<<endl;
        }
        while(!a.empty())
          a.pop();
       
      }
      return 0;
    }
     
  • 相关阅读:
    postman: 字符串与数字的转换
    postman:截取字符串字符
    postman:获取txt变量中数据
    postman:参数化外部文件txt、csv、json
    postman:全局变量、环境变量、collection模块变量
    windows下更新python报错permission denied
    vertica 7.0 使用kafka
    Kafka报错-as it has seen zxid 0x83808 our last zxid is 0x0 client must try another server
    vertica 8.0 新特性
    mysql source导入报错ERROR 1366的解决方法
  • 原文地址:https://www.cnblogs.com/-citywall123/p/10540466.html
Copyright © 2011-2022 走看看