zoukankan      html  css  js  c++  java
  • POJ1651 Multiplication Puzzle 区间DP

    Multiplication Puzzle

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 14834   Accepted: 9107

    Description

    The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

    The goal is to take cards in such order as to minimize the total number of scored points. 

    For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
    10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

    If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
    1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

    Input

    The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

    Output

    Output must contain a single integer - the minimal score.

    Sample Input

    6
    10 1 50 50 20 5
    

    Sample Output

    3650

    题目大意

    给定你一个序列,其中取走一个数的代价是它乘上它相邻的两个数

    两头的数不可以取~

    求最小代价

    状态转移方程:

    设状态函数dp[i][j],表示从第i个数到第j个数抽取完后的最小值。一开始初始化为3个数,就只有3个数相乘。后面长度从3增加到n,则状态转移方程为

    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i]*a[k]*a[j])     (i<k<j)其中k表示在i...j中最后抽的牌是a[k].

    #include<iostream>
    #include<string.h>
    #include<string>
    #include<math.h>
    using namespace std;
    int a[105],dp[105][105];//dp表示从第i个数到第j个数抽取完后的最小值
    int n;
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>a[i];
        for(int i=1;i+1<n;i++)//初始化
            dp[i][i+2]=a[i]*a[i+1]*a[i+2];
        for(int len=4;len<=n;len++)
        {
            for(int i=1;i+len-1<=n;i++)
            {
                int j=i+len-1;
                dp[i][j]=99999999;  
                for(int k=i+1;k<j;k++)//其中k表示在i...j中最后抽的牌是a[k].
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[k]*a[i]*a[j]);
            }
        }
        cout<<dp[1][n]<<endl;
        return 0;
    
    }
  • 相关阅读:
    spring3.1, hibernate4.1 配置备份,struts2.2.1,sitemesh 2.4.2
    java 动态AOP
    制作可以执行的 JAR 文件包及 jar 命令详解
    struts result Annotation 参考
    Android线段与矩形碰撞检测函数
    防止aspxspy木马列服务 iis信息 执行命令提权等操作
    博客园申请及页面定制CSS
    C# 中将月份格式化为英语缩写格式
    通过Web Service获取天气预报并朗读
    windows下html/javascript调用可执行程序
  • 原文地址:https://www.cnblogs.com/-citywall123/p/10901891.html
Copyright © 2011-2022 走看看