zoukankan      html  css  js  c++  java
  • poj_2421_mst

    D - Constructing Roads
    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

    Input

    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

    Output

    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

    Sample Input

    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
    

    Sample Output

    179

    刚开始用kruskal,结果tle 了,可能是我的代码写挫了吧。改为prim,wa了,改了cost[u][v]=cost[v][u]


    #include<cstdio>
    #include<cstring>
    const int INF=0x3f3f3f;
    const int MAXN=110;//看清上限
    bool vis[MAXN];
    int lowc[MAXN];
    int cost[MAXN][MAXN];
    int prim(int n)
    {
      memset(vis,false,sizeof(vis));
      int ans=0;
      vis[1]=true;
      for(int i=2;i<=n;i++)
        lowc[i]=cost[1][i];
      for(int i=2;i<=n;i++)//我开始这里写成了i=1;当然一直是return -1;
      {
        int minc=INF;
        int p=-1;
        for(int j=1;j<=n;j++)
          if(!vis[j]&&lowc[j]<minc)
          {
            minc=lowc[j];
            p=j;
          }
        if(minc==INF)
          return -1;
        ans+=minc;
        vis[p]=true;
        for(int j=1;j<=n;j++)
          if(!vis[j]&&cost[p][j]<lowc[j])
            lowc[j]=cost[p][j];
      }
      return ans;
    }
    int main()
    {
      int n;
      while(scanf("%d",&n)!=EOF)
      {
        int w;
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
            cost[i][j]=INF;
        for(int i=1;i<=n;i++)
        {
          lowc[i]=INF;
          for(int j=1;j<=n;j++)
          {
            scanf("%d",&w);
            if(w<cost[i][j])//只保存最小权值
            cost[i][j]=w;
          }
        }
        int m;
        scanf("%d",&m);
        int u,v;
        for(int i=1;i<=m;i++)
        {
          scanf("%d%d",&u,&v);
          cost[u][v]=cost[v][u]=0;//这里不能只写cost[u][v]=0;
        }
        int ans=prim(n);
        printf("%d ",ans);//我忘了要
      }
      return 0;
    }













  • 相关阅读:
    了解jQuery Validate.JS后不用再为正则验证头疼
    Javascripty(数组字符串篇)
    Javascripty(中篇)
    javascript(入门篇)
    Git与Github(初基础)
    解释ajax的工作原理
    rem是什么
    图片懒加载
    Angular中使用Swiper不能滑动的解决方法
    关于Iscroll.js 的滑动和Angular.js路由冲突问题
  • 原文地址:https://www.cnblogs.com/-maybe/p/4233621.html
Copyright © 2011-2022 走看看