zoukankan      html  css  js  c++  java
  • poj 2506 递推+Java大数

    Description

    In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
    Here is a sample tiling of a 2x17 rectangle.

    Input

    Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

    Output

    For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

    Sample Input

    2
    8
    12
    100
    200

    Sample Output

    3
    171
    2731
    845100400152152934331135470251
    1071292029505993517027974728227441735014801995855195223534251

    分析:

    题目大意就是有2×1和2×2两种规格的地板,现要拼2×n的形状,共有多少种情况,首先要做这道题目要先对递推有一定的了解。
    假设我们已经铺好了2×(n-1)的情形,则要铺到2×n则只能用2×1的地板
    假设我们已经铺好了2×(n-2)的情形,则要铺到2×n则可以选择1个2×2或两个2×1,故可能有下列三种铺法

        

    其中要注意到第三个会与铺好2×(n-1)的情况重复,故不可取,故可以得到递推式

    a[i]=2*a[i-2]+a[i-1];

    有了递推公式,直接用java大数做就好:


    import java.io.*;
    import java.math.*;
    import java.util.*;
    public class Main{
    	static public void main(String[] args) {
    		
    		Scanner cin=new Scanner(new BufferedInputStream(System.in));
    		BigInteger [] a=new BigInteger[255];
    		a[0]=a[1]=BigInteger.ONE;
    		a[2]=a[1].add(a[0].add(a[0]));
    		for(int i=3;i<252;i++){
    			a[i]=a[i-1].add(a[i-2].add(a[i-2]));
    		}
    		int n;
    		while(cin.hasNext()){
    			n=cin.nextInt();
    			System.out.println(a[n]);
    		}
    	}
    }




  • 相关阅读:
    IplImage, CvMat, Mat 的关系
    neon memory copy
    基于v4l2的webcam应用, 本地预监
    makefile写法实例
    Ubuntu 12.04 使用Eclipse搭建C/C++编译环境
    xapp1167与TRD14.4 关系
    v3学院带你一次性认清UART、RS-232、RS-422、RS-485的区别
    v3学院教你学习-task和function的异同
    寒假参加V3
    FPGA培训学习心得
  • 原文地址:https://www.cnblogs.com/01world/p/5651232.html
Copyright © 2011-2022 走看看