zoukankan      html  css  js  c++  java
  • PAT1092:To Buy or Not to Buy

    1092. To Buy or Not to Buy (20)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

    For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.


    Figure 1

    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:
    ppRYYGrrYBR2258
    YrR8RrY
    
    Sample Output 1:
    Yes 8
    
    Sample Input 2:
    ppRYYGrrYB225
    YrR8RrY
    
    Sample Output 1:
    No 2

    思路
    用map模拟一个字典。nomiss记录满足需求的珠子数,buy记录买来的项链上多余珠子数。
    1.把需要的项链的珠子放进字典里并计数,如dic<珠子类别,珠子数>形式。
    2.检查买来的项链上的每一个珠子,如果在字典里存在,则字典对应的珠子数减1,减1后如果为0则把对应珠子从字典里删掉。如果不存在buy++。
    3.检查字典是否为空,为空表示买来的项链满足需求的项链,输出多买的珠子数量buy;不为空表示买来的项链的珠子类别没有满足需求的项链,输出需求项链缺失的珠子数量miss(miss = 需求项链的长度- nomiss)
    代码
    #include<iostream>
    #include<string>
    #include<map>
    using namespace std;
    int main()
    {
       string shop,need;
       while(cin >> shop >> need)
       {
         //Initialize
         int buy = 0;
         int nomiss = 0;
         map<char,int> dic;
         for(int i = 0;i < need.size();i++)
         {
             if(dic.count(need[i]) > 0)
                 dic[need[i]]++;
             else
                 dic.insert(pair<char,int>(need[i],1));
         }
         for(int i = 0;i < shop.size();i++)
         {
             if(dic.count(shop[i]) > 0)
             {
                if(--dic[shop[i]] == 0)
                {
                    dic.erase(shop[i]);
                }
                nomiss++;
             }
             else
                buy++;
         }
         if(dic.empty())
            cout << "Yes" << " " << buy;
         else
            cout << "No" << " " << need.size() - nomiss;
       }
    }
     
  • 相关阅读:
    leetcode -- 4Sum
    leetcode -- 3Sum Closest
    leetcode -- 3Sum
    leetcode -- Longest Common Prefix
    leetcode -- Container With Most Water
    leetcode -- Palindrome Number
    rep stos 指令(Intel汇编)
    利用反汇编手段解析C语言函数
    C语言反汇编入门实例
    系统栈的工作原理
  • 原文地址:https://www.cnblogs.com/0kk470/p/7623043.html
Copyright © 2011-2022 走看看