zoukankan      html  css  js  c++  java
  • PAT1083:List Grades

    1083. List Grades (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

    Input Specification:

    Each input file contains one test case. Each case is given in the following format:

    N
    name[1] ID[1] grade[1]
    name[2] ID[2] grade[2]
    ... ...
    name[N] ID[N] grade[N]
    grade1 grade2
    

    where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output "NONE" instead.

    Sample Input 1:
    4
    Tom CS000001 59
    Joe Math990112 89
    Mike CS991301 100
    Mary EE990830 95
    60 100
    
    Sample Output 1:
    Mike CS991301
    Mary EE990830
    Joe Math990112
    
    Sample Input 2:
    2
    Jean AA980920 60
    Ann CS01 80
    90 95
    
    Sample Output 2:
    NONE

    思路
    要求按成绩降序输出给定成绩区间学生的信息。考虑到成绩不超过100而且唯一,可以用桶排序的思想来直接排序输出而不用比较。
    1.用两种桶name[101]和ID[101]分别存放姓名和ID。
    2.用成绩代表桶的下标,把对应成绩的学生信息放入桶中。如Jack CS00001 60 ---等价于---> name[60] = "Jack", ID[60] = "CS00001"。
    3.根据区间范围输出不为空的桶里面的信息即可。如果范围内的桶都为空输出"NONE"。
    代码
    #include<iostream>
    #include<vector>
    #include<string>
    using namespace std;
    vector<string> name(101);
    vector<string> ID(101);
    
    int main()
    {
      int N;
      while(cin >> N)
      {
        string n,id;
        for(int i = 0;i < N;i++)
        {
            int grade;
            cin >> n >> id >> grade;
            name[grade] = n;
            ID[grade] = id;
        }
        int j,k;
        bool isNone = true;
        cin >> j >> k;
        for(;k >= j;k--)
        {
            if(name[k] != "")
            {
              isNone = false;
              cout << name[k] << " " << ID[k] << endl;
            }
        }
        if(isNone)
            cout <<"NONE" << endl;
        ID.clear();
        name.clear();
      }
    }
     
  • 相关阅读:
    算法与设计模式
    Python开源应用系统
    ASP.NET MVC配置Redis服务
    常用3个框架
    Visual Studio 2015 编译错误 File 的值+乱码的解决方法
    SQL Server2008 R2命令行启动及停止SQL服务的方法
    Linux Shell查看物理CPU个数、核数、逻辑CPU个数
    SQL SERVER 2008R2 执行大脚本文件时,管理工具提示“内存不足”的解决方法
    MVC中未能加载程序集System.Web.Http/System.Web.Http.WebHost
    Windows10中启用原来的Windows照片查看器方法
  • 原文地址:https://www.cnblogs.com/0kk470/p/7623064.html
Copyright © 2011-2022 走看看