zoukankan      html  css  js  c++  java
  • PAT1017:Queueing at Bank

    1017. Queueing at Bank (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

    Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

    Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

    Output Specification:

    For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

    Sample Input:
    7 3
    07:55:00 16
    17:00:01 2
    07:59:59 15
    08:01:00 60
    08:00:00 30
    08:00:02 2
    08:03:00 10
    
    Sample Output:
    8.2

    思路

    贪心策略,将办理业务的人按到达时间递增排序,先来的优先服务(将时间统一转换为秒方便计算)。
    注意:
    1.业务办理时间不应超过1小时。
    2.17点之后来的人不提供服务。
    3.一个窗口的空闲时刻有两种情况:
    1)空闲直到下一个人customer[i]到达银行办理业务,那么这个窗口的下一个空闲时刻为customer[i]的到达时间加上他办理业务需要的时间。
    2)如果在一个窗口空闲前,custmoer[i]就先来了,那么他需要等(窗口空闲时间-他到达的时间)这么一段时间。该窗口的下一个空闲时刻就是它当前空闲时刻加上customer[i]的业务办理时间。

    代码
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<iomanip>
    using namespace std;
    class person
    {
    public:
        int cometime;
        int taketime;
        person(int ct,int tt)
        {
            cometime = ct;
            taketime = tt;
        }
    };
    
    /*贪心策略 先来的先服务,有空窗口就服务*/
    
    bool cmp(const person& a,const person& b)
    {
        return a.cometime < b.cometime;
    }
    
    int main()
    {
       int N,K;
       vector<person> customer;
       while(cin >> N >> K)
       {
          vector<int> windows(K,28800);
          for(int i = 0;i < N;i++)
          {
              int hh,mm,ss,lasttime;
              scanf("%d:%d:%d %d",&hh,&mm,&ss,&lasttime);
              if(lasttime > 60)
                lasttime = 60;
              lasttime *= 60;
              int arrivetime = hh * 3600 + mm * 60 + ss;
              if(arrivetime > 61200)
                 continue;
              customer.push_back(person(arrivetime,lasttime));
          }
          sort(customer.begin(),customer.end(),cmp);
          double waitTime = 0;
          for(int i = 0;i < customer.size();i++)
          {
              int minwindow = windows[0],tmpindex = 0;
              for(int j = 0;j < K;j++)
              {
                  if(windows[j] < minwindow)
                  {
                      minwindow = windows[j];
                      tmpindex = j;
                  }
              }
              if(customer[i].cometime >= minwindow)
              {
                  windows[tmpindex] = customer[i].cometime + customer[i].taketime;
              }
              else
              {
                  waitTime += minwindow - customer[i].cometime;
                  windows[tmpindex] += customer[i].taketime;
              }
          }
          if(customer.empty())
            cout << "0.0" << endl;
          else
            cout << fixed << setprecision(1) << waitTime/60.0/customer.size() << endl;
       }
    }
    

      

  • 相关阅读:
    FCKeditor 2.3 在ASP.NET中的设置和使用
    如何去掉重复记录的Sql语句写法
    asp.net如何去掉HTML标记
    Asp.net中如何删除cookie?
    怎样得到select所有option里的值
    HttpModule是如何工作的
    Asp.net2.0下的表单验证Cookieless属性
    FreeTextBox实现机制
    ajax实现动态从数据库模糊查询显示到下拉框中(ajax方法返回Dataset的例子)
    新浪博客自动发表程序,请勿用于非法用途
  • 原文地址:https://www.cnblogs.com/0kk470/p/7929627.html
Copyright © 2011-2022 走看看