zoukankan      html  css  js  c++  java
  • PAT1029:Median

    1029. Median (25)

    时间限制
    1000 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output

    For each test case you should output the median of the two given sequences in a line.

    Sample Input
    4 11 12 13 14
    5 9 10 15 16 17
    
    Sample Output
       13
     
    思路
     水题,将两个数组合并后排序就行,注意偶数个数字的数组的median是靠左的数。
    代码
    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main()
    {
       int n;
       while(cin >> n)
       {
           vector<int> seq1(n);
           for(int i = 0;i < n;i++)
           {
               cin >> seq1[i];
           }
           int m;
           cin >> m;
           vector<int> seq2(m);
           for(int i = 0;i < m;i++)
           {
               cin >> seq2[i];
           }
           seq1.insert(seq1.end(),seq2.begin(),seq2.end());
           sort(seq1.begin(),seq1.end());
           cout << seq1[(m + n - 1)/2] << endl;
       }
    }
    

      

  • 相关阅读:
    jquery mobile pages之间的跳转
    Javascript中this、prototype、constructor的理解
    javaScript的引号使用
    javaScript的事件
    我的css
    HTML5 canvas的事件
    java动态代理
    (转)面向对象的 JavaScript 编程:dojo.declare 详解
    Speex手册编解码介绍 中文翻译
    Android修改自己程序字体
  • 原文地址:https://www.cnblogs.com/0kk470/p/7930065.html
Copyright © 2011-2022 走看看