zoukankan      html  css  js  c++  java
  • PAT1136:A Delayed Palindrome

    1136. A Delayed Palindrome (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Consider a positive integer N written in standard notation with k+1 digits ai as ak...a1a0 with 0 <= ai < 10 for all i and ak > 0. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 and is also palindromic by definition.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number)

    Given any positive integer, you are supposed to find its paired palindromic number.

    Input Specification:

    Each input file contains one test case which gives a positive integer no more than 1000 digits.

    Output Specification:

    For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

    A + B = C
    

    where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line "C is a palindromic number."; or if a palindromic number cannot be found in 10 iterations, print "Not found in 10 iterations." instead.

    Sample Input 1:
    97152
    
    Sample Output 1:
    97152 + 25179 = 122331
    122331 + 133221 = 255552
    255552 is a palindromic number.
    
    Sample Input 2:
    196
    
    Sample Output 2:
    196 + 691 = 887
    887 + 788 = 1675
    1675 + 5761 = 7436
    7436 + 6347 = 13783
    13783 + 38731 = 52514
    52514 + 41525 = 94039
    94039 + 93049 = 187088
    187088 + 880781 = 1067869
    1067869 + 9687601 = 10755470
    10755470 + 07455701 = 18211171
    Not found in 10 iterations.

    思路
    Pat1024 一样的题目,字符串处理问题。
    代码
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    bool isPalindrome(const string& s)
    {
      for(int i = 0,j = s.size() - 1;i <= j;i++,j--)
      {
          if(s[i] != s[j])
            return false;
      }
      return true;
    }
    
    string add(const string& a,const string& b)
    {
        string tmp;
        int len = a.size();
        int carry = 0;
        for(int i = len - 1;i >= 0;i--)
        {
            int cur = (a[i] - '0') + (b[i] - '0') + carry;
            carry = cur / 10;
            cur = cur % 10;
            tmp += (to_string(cur));
        }
        reverse(tmp.begin(),tmp.end());
        if(carry > 0)
            tmp.insert(0,"1");
        return tmp;
    }
    
    int main()
    {
       string a;
       while(cin >> a)
       {
          int cnt = 0;
          while(!isPalindrome(a) && ++cnt <= 10)
          {
              string b = a;
              reverse(b.begin(),b.end());
              string c = add(a,b);
              cout << a << " + " << b << " = " << c << endl;
              a = c;
          }
          if(cnt == 11)
            cout << "Not found in 10 iterations." << endl;
          else
            cout << a << " is a palindromic number." << endl;
       }
    }
    

      

  • 相关阅读:
    《贝叶斯优化: 一种更好的超参数调优方式》
    《从Google Visor到Microsoft NNI再到Advisor调参服务接口发展史》
    《归一化激活层的进化:谷歌Quoc Le等人利用AutoML 技术发现新型ML模块》
    《通用视觉 & NAS》
    《Object Detection-IOU Net笔记》
    《Detectron2之ROIAlign》
    《IoUNet(6)_源码_RoIAlign(1)》
    聊天机器人资源合集:项目,语聊,论文,教程。
    一个使用 Python 的人工智能聊天机器人框架
    【TensorFlow 官网 可以直接访问】让中国开发者更容易地使用TensorFlow打造人工智能应用
  • 原文地址:https://www.cnblogs.com/0kk470/p/8026897.html
Copyright © 2011-2022 走看看