zoukankan      html  css  js  c++  java
  • PAT1049:Counting Ones

    1049. Counting Ones (30)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

    Input Specification:

    Each input file contains one test case which gives the positive N (<=230).

    Output Specification:

    For each test case, print the number of 1's in one line.

    Sample Input:
    12
    
    Sample Output:
    5

    思路
    给一个数,计算所有小于等于这个数的数字中的1的个数和。
    找规律题,计算每一位对应的1的个数,然后相加,每一位的1的计算情况分三种情况:
    1.如果当前位数字为0,那么该位的1的个数由更高位的数字确定。比如2120,个位为1的个数为212 * 1 = 212(个位的单位为1)。
    2.如果当前位数字为1,那么该位的1的个数不但由高位决定,还由低位数字决定。比如2120百位为1,那么百位数字1的个数为2 * 100 + 20 + 1 = 221个(百位的单位为100)。
    3.如果当前位数字大于1,那么该位数字1的个数为(高位数+ 1) * 位数单位。比如2120十位为2,那么十位数字1的个数为(21 + 1) * 10 = 220个(十位的单位为10)
    4.继续按照上文,2120千位为2,那么千位为1的个数为(0 + 1)*1000 = 1000
    5.综上2120以内的所有数字中出现1的个数为1653个。

    代码
    #include<iostream>
    using namespace std;
    
    int CountOnes(int n)
    {
        int factor = 1,lownum = 0,highnum = 0,cur = 0,countones = 0;
        while(n/factor)
        {
            highnum = n/(factor*10);
            lownum = n - (n/factor)*factor;
            int cur = (n/factor) % 10;
            if(cur == 0)
            {
                 countones += highnum * factor;
            }
            else if (cur == 1)
            {
                 countones += highnum * factor + lownum + 1;
            }
            else
            {
                countones += ( highnum + 1) * factor;
            }
            factor *= 10;
        }
        return countones;
    }
    
    int main()
    {
        int n;
        while(cin >> n)
        {
            cout << CountOnes(n);
        }
    }
    

      

  • 相关阅读:
    《流畅的Python》Data Structures--第7章 colsure and decorator
    CSS Reset 2.0标准
    Layout
    一个简单的例子 vux mutation改变状态
    __WEBPACK_IMPORTED_MODULE_3_vuex__.a is not a constructor
    vuex 使用
    (转)Vue-初步了解vue-router的三要素:路由map 、路由视图、路由导航
    router-link-active 和 router-link-exact-active router-link-active
    当前目录 根目录 写法
    mode: 'history', 去掉路由地址的#
  • 原文地址:https://www.cnblogs.com/0kk470/p/8075133.html
Copyright © 2011-2022 走看看