zoukankan      html  css  js  c++  java
  • PAT1055:The World's Richest

    1055. The World's Richest (25)

    时间限制
    400 ms
    内存限制
    128000 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

    Output Specification:

    For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

    Name Age Net_Worth
    
    The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None". Sample Input:
    12 4
    Zoe_Bill 35 2333
    Bob_Volk 24 5888
    Anny_Cin 95 999999
    Williams 30 -22
    Cindy 76 76000
    Alice 18 88888
    Joe_Mike 32 3222
    Michael 5 300000
    Rosemary 40 5888
    Dobby 24 5888
    Billy 24 5888
    Nobody 5 0
    4 15 45
    4 30 35
    4 5 95
    1 45 50
    
    Sample Output:
    Case #1:
    Alice 18 88888
    Billy 24 5888
    Bob_Volk 24 5888
    Dobby 24 5888
    Case #2:
    Joe_Mike 32 3222
    Zoe_Bill 35 2333
    Williams 30 -22
    Case #3:
    Anny_Cin 95 999999
    Michael 5 300000
    Alice 18 88888
    Cindy 76 76000
    Case #4:
    None

    思路
    排序题,需要注意的是对输入的数据要预处理下,比如在某个年龄的人数达到100后就不用再将剩余的该年龄点的人插入数据集了(M最大为100),因为不管怎么查,输出只会是某个年龄段的前100富翁。
    代码
    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    
    class person
    {
    public:
        string name;
        int age;
        int worth;
    };
    
    
    bool cmp(const person& a,const person& b)
    {
        if(a.worth != b.worth)
            return a.worth > b.worth;
        else if(a.age != b.age)
            return a.age < b.age;
        else
            return a.name.compare(b.name) < 0;
    }
    
    int main()
    {
       int n,k;
       vector<int> age_count(201,0);
       vector<person> res;
       while(cin >> n >> k)
       {
           vector<person> people(n);
           for(int i = 0;i < n;i++)
           {
               cin >> people[i].name >> people[i].age >> people[i].worth;
           }
           sort(people.begin(),people.end(),cmp);
           for(int i = 0;i < people.size();i++)  //减小查找量
           {
                if(age_count[people[i].age] < 100)
                {
                    res.push_back(people[i]);
                    age_count[people[i].age]++;
                }
           }
           for(int i = 1;i <= k;i++)
           {
               vector<person> output;
               int cnt = 0,maxcnt,age_min,age_max;
               cin >> maxcnt >> age_min >> age_max;
               for(int j = 0;j < res.size() && cnt < maxcnt;j++)
               {
                   if(res[j].age >= age_min && res[j].age <= age_max)
                   {
                       output.push_back(res[j]);
                       cnt++;
                   }
               }
               if(output.empty())
                  cout << "Case #" << i << ":
    " << "None" << endl;
               else
               {
                  cout << "Case #" << i << ":" << endl;
                  for(int j = 0;j < output.size();j++)
                  {
                      cout << output[j].name << " " << output[j].age << " " << output[j].worth << endl;
                  }
               }
           }
       }
    }
    

      

  • 相关阅读:
    ab 性能测试工具的使用(Web并发测试)
    java 读取文件——按照行取出(使用BufferedReader和一次将数据保存到内存两种实现方式)
    java 判断两个时间相差的天数
    java 正则表达式的应用:读取文件,获取其中的电话号码
    mybatis 插入数据时返回主键
    CodeForces 493B Vasya and Wrestling 【模拟】
    图像边缘检測小结
    【JS设计模式】温习简单工厂模式、工厂方法模式、抽象工厂模式概念
    60.自己定义View练习(五)高仿小米时钟
    bzoj4361 isn
  • 原文地址:https://www.cnblogs.com/0kk470/p/8177758.html
Copyright © 2011-2022 走看看