zoukankan      html  css  js  c++  java
  • PAT1012:The Best Rank

    1012. The Best Rank (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

    For example, The grades of C, M, E and A - Average of 4 students are given as the following:

    StudentID  C  M  E  A
    310101     98 85 88 90
    310102     70 95 88 84
    310103     82 87 94 88
    310104     91 91 91 91
    

    Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

    Input

    Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

    Output

    For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

    The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

    If a student is not on the grading list, simply output "N/A".

    Sample Input
    5 6
    310101 98 85 88
    310102 70 95 88
    310103 82 87 94
    310104 91 91 91
    310105 85 90 90
    310101
    310102
    310103
    310104
    310105
    999999
    
    Sample Output
    1 C
    1 M
    1 E
    1 A
    3 A
    N/A

    思路

    排序 + 查找。
    1.首先按顺序输入学生id和ACME四门课的成绩。
    2.分别比较ACME四门成绩的高低来决定学生的ACME的四个对应排名。
    3.找到每一个学生中成绩排名最高的那门课的索引,并将学生id和学生当前排名位置索引插入一个map中。
    4.输出学生的最好成绩的课程索引对应的最好排名和课程代号,如果学生id在map中不存在,输出N/A。

    代码
    #include<vector>
    #include<map>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    
    class student
    {
    public:
        student():myrank(4),grade(4)
        {
    
        }
        string id;
        int best_index;
        vector<int> myrank;
        vector<int> grade;
    };
    vector<char> grade_id = {'A','C','M','E'};
    vector<student> students;
    map<string,int> exists;
    int index = 0;
    
    bool cmp(const student& a,const student& b)
    {
        return a.grade[index] > b.grade[index];
    }
    
    
    int main()
    {
       int N,M;
       while(cin >> N >> M)
       {
          students.resize(N);
          for(int i = 0;i < N;i++)
          {
              cin >> students[i].id >> students[i].grade[1] >> students[i].grade[2] >> students[i].grade[3];
              students[i].grade[0] = (students[i].grade[1] + students[i].grade[2] + students[i].grade[3])/3;
          }
    
          //ACME sort
          for(;index <= 3;index++)
          {
              sort(students.begin(),students.end(),cmp);
              students[0].myrank[index] = 1;
              for(int i = 1;i < N;i++)
              {
                  students[i].myrank[index] = i + 1;
                  if(students[i - 1].grade[index] == students[i].grade[index])
                  {
                     students[i].myrank[index] = students[i - 1].myrank[index];
                  }
              }
          }
    
          //find best
          for(int i = 0;i < N;i++)
          {
              exists[students[i].id] = i;
              int minnum = students[i].myrank[0];
              for(int j = 1;j <= 3;j++)
              {
                  if(students[i].myrank[j] < minnum)
                  {
                      minnum = students[i].myrank[j];
                      students[i].best_index = j;
                  }
              }
          }
    
          //query and output
          for(int i = 0;i < M;i++)
          {
              string id;
              cin >> id;
              if(exists.count(id) <= 0)
              {
                  cout << "N/A" << endl;
              }
              else
              {
                 int bindex = students[exists[id]].best_index;
                 cout << students[exists[id]].myrank[bindex] << " " << grade_id[bindex] << endl;
              }
          }
    
       }
    }
    

      

  • 相关阅读:
    快速排序
    fedora 配置
    while与do while
    switch选择结构
    if选择结构
    java有参
    java猜拳
    java类的无参方法
    java类与对象
    java数组
  • 原文地址:https://www.cnblogs.com/0kk470/p/8178303.html
Copyright © 2011-2022 走看看