zoukankan      html  css  js  c++  java
  • bzoj 1634: [Usaco2007 Jan]Protecting the Flowers 护花

    Time Limit: 5 Sec  Memory Limit: 64 MB

    Description

    Farmer John went to cut some wood and left N (2 <= N <= 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cows were in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport the cows back to their barn. Each cow i is at a location that is Ti minutes (1 <= Ti <= 2,000,000) away from the barn. Furthermore, while waiting for transport, she destroys Di (1 <= Di <= 100) flowers per minute. No matter how hard he tries,FJ can only transport one cow at a time back to the barn. Moving cow i to the barn requires 2*Ti minutes (Ti to get there and Ti to return). Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

       约翰留下他的N只奶牛上山采木.他离开的时候,她们像往常一样悠闲地在草场里吃草.可是,当他回来的时候,他看到了一幕惨剧:牛们正躲在他的花园里,啃食着他心爱的美丽花朵!为了使接下来花朵的损失最小,约翰赶紧采取行动,把牛们送回牛棚. 牛们从1到N编号.第i只牛所在的位置距离牛棚Ti(1≤Ti《2000000)分钟的路程,而在约翰开始送她回牛棚之前,她每分钟会啃食Di(1≤Di≤100)朵鲜花.无论多么努力,约翰一次只能送一只牛回棚.而运送第第i只牛事实上需要2Ti分钟,因为来回都需要时间.    写一个程序来决定约翰运送奶牛的顺序,使最终被吞食的花朵数量最小.

    Input

    * Line 1: A single integer

    N * Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

        第1行输入N,之后N行每行输入两个整数Ti和Di.

    Output

    * Line 1: A single integer that is the minimum number of destroyed flowers

        一个整数,表示最小数量的花朵被吞食.

    Sample Input

    6
    3 1
    2 5
    2 3
    3 2
    4 1
    1 6

    Sample Output

    86

    HINT

        约翰用6,2,3,4,1,5的顺序来运送他的奶牛.

    解:贪心,

    可以发现,调换序列中a与b的位置对于a和b以外的数是没有任何影响的

    如果 x.t*y.d<y.t*x.d(这是关键)

    x排在y前面会比y排在x前面更优,所以可以按照这个规则排序模拟

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #define ll long long
    using std::sort;
    const int N=100010;
    struct node
    {
        int t,d;
    }map[N];
    ll ans=0,sum=0;
    bool cmp(node x,node y){return x.t*y.d<y.t*x.d;}
    int main()
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d",&map[i].t,&map[i].d);
            sum+=map[i].d;
        }
        sort(map+1,map+1+n,cmp);
        for(int i=1;i<=n;i++)
        {
            sum-=map[i].d;
            ans+=sum*(map[i].t<<1);
        }
        printf("%lld",ans);
        return 0;    
    }
    View Code
  • 相关阅读:
    MFC生成的exe程序不能在其他电脑上运行怎么办
    MFC开发软件支持多语言且同时支持xp和win7操作系统
    MFC创建模态对话框与非模态对话框
    如何定位BAD_ACCESS
    iOS中几种数据持久化方案
    iOS NSString相关问题
    SPU
    WIKI
    Mac怎么快速创建便签和发送附件的邮件
    利用你的Mission Control--设置快速回到桌面等操作
  • 原文地址:https://www.cnblogs.com/12fs/p/7637350.html
Copyright © 2011-2022 走看看