zoukankan      html  css  js  c++  java
  • poj2109

    Power of Cryptography
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 20371   Accepted: 10293

    Description

    Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
    This problem involves the efficient computation of integer roots of numbers. 
    Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

    Input

    The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

    Output

    For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

    Sample Input

    2 16
    3 27
    7 4357186184021382204544

    Sample Output

    4
    3
    1234

    Source

     
     
     
     
     
     
     
     
     
    double   10的308次幂到负的308
    #include<iostream>
    #include<cmath>
    using namespace std;
    int main()
    {
        double n,m;
        while(cin>>n>>m)
        {
            n=(double)pow(m,1/n);
            cout<<n<<endl;
        }
        return 0;
    }
  • 相关阅读:
    日期操作
    sanchi
    502 Server dropped connection
    把项目挂载到composer上
    从composer上在本地创建一个项目
    初始化后,composer安装
    在项目目录初始化composer
    Linux安装composer
    linux网络编程之TCP/IP基础
    grep的用法
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4617416.html
Copyright © 2011-2022 走看看