zoukankan      html  css  js  c++  java
  • poj1573 模拟

    Robot Motion
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 11270   Accepted: 5487

    Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page) 
    S south (down the page) 
    E east (to the right on the page) 
    W west (to the left on the page) 

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

    Input

    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

    Output

    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

    Sample Input

    3 6 5
    NEESWE
    WWWESS
    SNWWWW
    4 5 1
    SESWE
    EESNW
    NWEEN
    EWSEN
    0 0 0

    Sample Output

    10 step(s) to exit
    3 step(s) before a loop of 8 step(s)






    没什么可说的,做不出来可以考虑退出ACM了

    #include<stdio.h>
    #include<string.h>
    char map[100][100];
    int vis[100][100];
    int flag;
    int x,y,h;
    void dfs(int tx,int ty){
    if(flag==1)
    return;
    if(map[tx][ty]=='N')
    tx-=1;
    else if(map[tx][ty]=='S')
    tx+=1;
    else if(map[tx][ty]=='W')
    ty-=1;
    else if(map[tx][ty]=='E')
    ty+=1;
    if(tx<1||tx>x||ty<1||ty>y)
    return;
    if(vis[tx][ty]==0){
    vis[tx][ty]=1;
    dfs(tx,ty);
    }
    else if(vis[tx][ty]==1){
    vis[tx][ty]=2;
    dfs(tx,ty);
    }
    else {
    flag=1;
    return;
    }
    }
    int main(){

    while(scanf("%d%d%d",&x,&y,&h)!=EOF){
    if(x==0&&y==0&&h==0)
    break;
    memset(vis,0,sizeof(vis));
    memset(map,0,sizeof(map));
    getchar();
    for(int i=1;i<=x;i++)
    gets(map[i]+1);
    int tx=1,ty=h;
    flag=0;
    vis[tx][ty]=1;
    dfs(tx,ty);
    int sum1=0,sum2=0;
    for(int i=1;i<=x;i++){
    for(int j=1;j<=y;j++){
    if(vis[i][j]==1)
    sum1++;
    else if(vis[i][j]==2)
    sum2++;
    }
    }
    if(sum2==0)
    printf("%d step(s) to exit ",sum1);
    else
    printf("%d step(s) before a loop of %d step(s) ",sum1,sum2);
    }
    return 0;
    }

  • 相关阅读:
    poj3041(最小顶点覆盖)
    High-speed Charting Control--MFC绘制图表(折线图、饼图、柱形图)控件
    hdu 3183 A Magic Lamp(RMQ)
    Android studio 中创建AIDL Service
    cocos2d-x 3.0正式版 cmd创建project以及一键创建project
    【Machine Learning】决策树案例:基于python的商品购买能力预测系统
    【Machine Learning】机器学习及其基础概念简介
    【Machine Learning】Python开发工具:Anaconda+Sublime
    【HanLP】HanLP中文自然语言处理工具实例演练
    【HanLP】资料链接汇总
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4628792.html
Copyright © 2011-2022 走看看