zoukankan      html  css  js  c++  java
  • poj 1035 纯正的字符串水

    Spell checker
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 22673   Accepted: 8258

    Description

    You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
    ?deleting of one letter from the word; ?replacing of one letter in the word with an arbitrary letter; ?inserting of one arbitrary letter into the word. Your task is to write the program that will find all possible replacements from the dictionary for every given word.

    Input

    The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

    Output

    Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

    Sample Input

    i
    is
    has
    have
    be
    my
    more
    contest
    me
    too
    if
    award
    #
    me
    aware
    m
    contest
    hav
    oo
    or
    i
    fi
    mre
    #

    Sample Output

    me is correct
    aware: award
    m: i my me
    contest is correct
    hav: has have
    oo: too
    or:
    i is correct
    fi: i
    mre: more me









    #include<stdio.h>
    #include<string.h>
    #include<vector>
    #include<string>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    string s;
    int main(){
        vector<string>q;
        while(cin>>s){
            if(s=="#")
                break;
            q.push_back(s);
    
        }
        while(cin>>s){
                if(s=="#")
                break;
          int len=s.size();
          bool flag=false;
         cout<<s;
          for(int i=0;i<q.size();i++){
            if(s==q[i]){
                flag=true;
                cout<<" is correct"<<endl;
        break;
            }
          }
    
          if(!flag){
                cout<<":";
              for(int i=0;i<q.size();i++){
                int len1=q[i].size();
                int temp=len1-len;
                if(temp>1||temp<-1)
                    continue;
                int d=0;
                if(temp==0){
                    for(int j=0;j<len;j++){
                        if(s[j]!=q[i][j])
                            d++;
                    }
                    if(d==1)
                        cout<<' '<<q[i];
                }
    
                else if(temp==-1){
                    for(int j=0;j<len;j++){
                        if(s[j]==q[i][d]){
                            d++;
                        }
                    }
                    if(d==len1)
                        cout<<' '<<q[i];
                }
    
                else if(temp==1){
                    for(int j=0;j<len1;j++){
                        if(s[d]==q[i][j]){
                            d++;
                        }
                    }
                    if(d==len)
                        cout<<' '<<q[i];
                }
    
              }
      cout<<endl;
          }
    
    
    
        }
        return 0;
    }
  • 相关阅读:
    hdu 2795 Billboard
    serialusbfn.dll这个罪魁祸首搞得我郁闷之极(作者:wogoyixikexie@gliet)
    开发板买来后如何练习写驱动、开发BSP?(作者:wogoyixikexie@gliet)
    PB命令行——查看DLL导出函数
    【劲爆】发帖达到要求即可获得一块mini6410/OK6410开发板!
    GOD!我终于找到博客园设置博客文章图片签名的方法了!
    如何删除wince5.0控制面板的密码设置以及拨号等组件
    【原创】最值得推荐wince应用和wince驱动入门书籍
    gooogleman嵌入式联盟之图标初步设计进展
    2440 5.0BSP之OEMInterruptHandler函数
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4697157.html
Copyright © 2011-2022 走看看