zoukankan      html  css  js  c++  java
  • POJ 2367 Genealogical tree 拓扑排序

                                                                             Genealogical tree

    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.  And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.  Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    5
    0
    4 5 1 0
    1 0
    5 3 0
    3 0
    

    Sample Output

    2 4 5 3 1
    代码:
    /* 今早做了两题拓扑排序的题,会点皮毛了*/
    
    #include<cstdio>
    #include<queue>
    #include<vector>
    #include<iostream>
    #include<cstring>
    using namespace std ;
    #define M 110
    int in[M] , p[M] ; 
    queue<int>q ;
    vector<int>qe[M] ;
    bool vi[M] ; // 有些 点可能没有 进入 关系网
    int main()
    {
    	int i , j , n , m , mun , h ;
    	while( scanf( "%d" , &n ) != EOF ){
    		for( i = 1 ;i <= n ;i++)
    			qe[i].clear() ; 
    		mun = 0 ;h = 1 ;
    		while(!q.empty())
    			q.pop() ;
    		memset( vi , 0 , sizeof(vi) ) ;
    		for( i = 1 ; i <= n ;i++){
    			while(1){
    			scanf( "%d" ,&m ) ;
    			if( m == 0 ) break ;
    			qe[m].push_back(i) ;
    			in[i]++ ;
    			}	
    		}
    		for( i = 1; i <= n ;i++)
    			if( in[i] == 0 )
    		{
                 p[h++] = i ;//找出 没有 儿子的点 加入队列
    			 q.push(i) ;
    			 vi[i] = 1 ;
    			 mun++ ; 
    		}
    			while( !q.empty() ){
    				int f = q.front() ;q.pop() ;
    				for( i = 0  ;i < qe[f].size() ;i++ )
    					if( --in[qe[f][i]] == 0 ){   // 删除和f 相连的边 
    						p[h++] = qe[f][i] ;
    						q.push(qe[f][i]) ; 
    						vi[qe[f][i]] = 1 ;
    						mun++ ;
    					}
    			}
    			if( mun == n ){
    		  for( i = h - 1 ; i > 1 ;i-- )
    			  cout << p[i] << " " ;
    		  cout << p[1] << endl; 
    			}
    			else {
    				for( i = 1 ;i <= n ;i++)
    					if( vi[i] == 0 )
    						cout << i << " " ;
    				   for( i = h - 1 ; i > 1 ;i-- )
    			         cout << p[i] << " " ;
    				   cout << p[1] << endl ;
    				   
    			}
    	}
    }
    

      

  • 相关阅读:
    关于 使用python向qq好友发送消息(对爬虫的作用----当程序执行完毕或者报错无限给自己qq发送消息,直到关闭)
    关于爬虫的制定
    关于scrapy 使用代理相关问题
    scrapy 关于特殊字符的处理
    scrapy
    关于数据去重
    零基础掌握百度地图兴趣点获取POI爬虫(python语言爬取)(进阶篇)
    零基础掌握百度地图兴趣点获取POI爬虫(python语言爬取)(代码篇)
    计算机编号、硬盘序列号和Mac地址查询方法
    统计学(第七版)第二章 数据的收集
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3007109.html
Copyright © 2011-2022 走看看