zoukankan      html  css  js  c++  java
  • 二分 Aggressive cows

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 
    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C 
    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3

    代码;

    #include<cstdio>
    #include<iostream>
    #include<cmath>
    #include<algorithm>
    #include<cstring>
    using namespace std ;
    #define MAXN 1000010
    int a[MAXN] ;
    bool find( int x , int n , int c )
    {
        int i ,mun = 1 , p = a[1];
        for( i = 2 ; i <= n ;i++)
        {
            if( a[i] - p >= x )
            {
                mun++ ;
                p = a[i];
            }
        }
        if( mun >= c ) return 1 ;// 如果超过c 则说明mid小了
        else return 0 ;
    }
    int main()
    {
        int mid , low , high ;
        int i , n , m , c ;
        while( cin >> n >> c )
        {
        for( i = 1 ; i <= n ;i++)
                scanf( "%d" , &a[i] ) ;
        // 因为输入不是有序的
        sort( a + 1 , a + 1 + n ) ;
    
        low = 0 ; 
        high = ( a[1] + a[n] ) / ( c - 1 ) ;
        while( low <= high )
        {
            mid = ( low + high ) / 2 ;
            if( find(mid , n , c )) low = mid + 1 ;
            else high = mid - 1 ;
        }
        cout << low - 1 << endl ;
    }
    }
  • 相关阅读:
    Openjudge NOI题库 ch0111/01 查找最近的元素
    Openjudge NOI题库 ch0111/07 和为给定数
    Openjudge NOI题库 ch0111/08 不重复地输出数
    Openjudge NOI题库 ch0111/10 河中跳房子|NOIP2015 day2 stone
    Openjudge NOI题库 ch0111/t1776 木材加工
    SRM 508(2-1000pt)
    SRM 507(2-1000pt)
    SRM 504.5(2-1000pt)
    最小生成树专题总结
    SRM 506(2-1000pt)
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3072583.html
Copyright © 2011-2022 走看看