zoukankan      html  css  js  c++  java
  • poj 3122 Pie 二分

    Pie
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8258   Accepted: 3007   Special Judge

    Description

    My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 
    My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 
    What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

    Input

    One line with a positive integer: the number of test cases. Then for each test case:
    • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
    • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

    Output

    For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

    Sample Input

    3
    3 3
    4 3 3
    1 24
    5
    10 5
    1 4 2 3 4 5 6 5 4 2

    Sample Output

    25.1327
    3.1416
    50.2655
    代码:
    #include<cstdio>
    #include<iostream>
    #include<cmath>
    #include<algorithm>
    using namespace std ;
    #define MAX 10010
    #define we 1e-8
    int mun[MAX] ;
    const double  PI = acos( -1.0 ) ;
    int main()
    {
        int i ,n , m  ;
        int Mun , T ;
        double ans , high , low , mid ;
        cin >> T ;
        while(  T-- )
        {   
            scanf( "%d%d" , &n , &m );
            high = 0 ;m++ ;low = 0 ;
            for( i = 1; i <= n ;i++)
            {
                scanf( "%d" , &mun[i] ) ;
                if( mun[i] > high )
                    high = mun[i] ;
            }
            high = high + 1 ;
            while( high - low > we )
            {  
                mid = ( high + low ) / 2.0 ;
                Mun = 0 ;// 能分出mid*mid*pI 的数目
                for( i = 1 ;i <= n ;i++)
                {
                    Mun += ( int )(mun[i]*mun[i]*1.0)/( mid * mid ) ;
                }
                if( Mun >= m ) low = mid ;
                else high = mid ;
                ans = PI * mid * mid ;
            }
            printf( "%.4llf\n" , ans ) ;
        }
    
    }
  • 相关阅读:
    GateWay的简单使用
    SpringCloud项目注册到Nacos
    Hystrix整合Gateway
    Nginx配置socket.io集群
    windows搭建git服务
    解决gitLab上新建分支,idea中找不到对应分支问题
    mybatis mapper.xml的特殊操作符
    Chrome添加Axure RP插件
    idea Tomcat部署时没有update classes and resources
    缓存穿透,缓存击穿,缓存雪崩解决方案分析【转载】
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3072594.html
Copyright © 2011-2022 走看看