zoukankan      html  css  js  c++  java
  • zju 1295 Reverse Text

    Reverse Text

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.


    Input Specification

    The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.


    Output Specification

    For each test case, print a line containing the characters of the input line in reverse order.


    Sample Input

    3
    Frankly, I don't think we'll make much
    money out of this scheme.
    madam I'm adam


    Sample Output

    hcum ekam ll'ew kniht t'nod I ,ylknarF
    .emehcs siht fo tuo yenom
    mada m'I madam

    #include<iostream>
    #include<string>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int n;
        n=0;
        string s;
        char ss[80];
        while(cin.getline(ss,80))
        {
            if(n==0) n=1;
            else
                {
                 s=ss;
                reverse(s.begin(),s.end());
            cout<<s<<endl;
            }
          
            
        }
        return 0;
    }
    View Code

    #include<iostream>
    #include<string>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int n;
        n=0;
        string s;
        char ss[80];
        while(cin.getline(ss,80))
        {
         if(n==0) n=1;
         else
       {
           s=ss;
          reverse(s.begin(),s.end());
            cout<<s<<endl;
         }
         
           
        }
        return 0;
    }


     

  • 相关阅读:
    PHPExcel常用方法总结
    ThinkPHP多语言在分组下的用法!
    derby 的字符集
    最小化msn,skype到右下角(Win 7)
    用javascript控制 youtube动画,直接打开html会失败
    maven 的本地仓库
    excel读取csv的字符集问题
    在dos控制台显示utf8字符
    关于在php和mysql中日期型date,datetime,timestamp的使用
    用 java jar执行时的classpath的问题
  • 原文地址:https://www.cnblogs.com/2014acm/p/3885526.html
Copyright © 2011-2022 走看看