zoukankan      html  css  js  c++  java
  • zju 1295 Reverse Text

    Reverse Text

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.


    Input Specification

    The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.


    Output Specification

    For each test case, print a line containing the characters of the input line in reverse order.


    Sample Input

    3
    Frankly, I don't think we'll make much
    money out of this scheme.
    madam I'm adam


    Sample Output

    hcum ekam ll'ew kniht t'nod I ,ylknarF
    .emehcs siht fo tuo yenom
    mada m'I madam

    #include<iostream>
    #include<string>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int n;
        n=0;
        string s;
        char ss[80];
        while(cin.getline(ss,80))
        {
            if(n==0) n=1;
            else
                {
                 s=ss;
                reverse(s.begin(),s.end());
            cout<<s<<endl;
            }
          
            
        }
        return 0;
    }
    View Code

    #include<iostream>
    #include<string>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int n;
        n=0;
        string s;
        char ss[80];
        while(cin.getline(ss,80))
        {
         if(n==0) n=1;
         else
       {
           s=ss;
          reverse(s.begin(),s.end());
            cout<<s<<endl;
         }
         
           
        }
        return 0;
    }


     

  • 相关阅读:
    C语言多文件参数传递
    第十章 C++11新特性
    第九章 STL标准库(二)
    第八章 标准模板库STL(一)
    第七章 2.泛型编程(模板)
    第七章 1.输入输出与模板
    第六章 多态
    第五章 继承与派生
    第四章 运算符重载
    第三章 类与对象进阶
  • 原文地址:https://www.cnblogs.com/2014acm/p/3885526.html
Copyright © 2011-2022 走看看