zoukankan      html  css  js  c++  java
  • pat1002

    1002. A+B for Polynomials (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    This time, you are supposed to find A+B where A and B are two polynomials.

    Input

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

    Output

    For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

    Sample Input
    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    
    Sample Output
    3 2 1.5 1 2.9 0 3.2
    题意给一个n 项多项式。在给第几项的 n次,和系数。
    相加
    #include <iostream>
    #include<string.h>
    #include<stdio.h>
    #include<iomanip>
    using namespace std;
    double a[1000];
    int main()
    {
        int n, m;
        int max=0;
        memset(a,0,sizeof a);
        cin>>n;
        int c;
        double d;
        for(int i=0;i<n;i++)
        {
            cin>>c>>d;
            a[c]=a[c]+d;
            if(c>max)
                max=c;
        }
    
        cin>>m;
    
        for(int i=0;i<m;i++)
        {
            cin>>c>>d;
            a[c]=a[c]+d;
            if(c>max)
                max=c;
        }
         int num=0;
         for(int i=0;i<=max;i++)
         {
             if(a[i]!=0)
                num++;
    
         }
         cout<<num;
         for(int i=max;i>=0;i--)
      {
        if(a[i]!=0)
        {
          cout<<" "<<i<<" ";
        cout<<fixed<<setprecision(1)<<a[i];
        }
      }
      cout<<endl;
        return 0;
    }

    注意结果保存1位


    提交代码

  • 相关阅读:
    python_socket
    python_面向对象(其他)+异常处理+单实例
    并发编程——协程
    数据库开发——MySQL——数据类型——非数值类型
    ALGO-1 区间k大数查询
    数据库开发——MySQL——数据类型——数值类型
    BASIC-10 十进制转十六进制
    BASIC-9 特殊回文数
    BASIC-8 回文数
    BASIC-7 特殊的数字
  • 原文地址:https://www.cnblogs.com/2014slx/p/7776616.html
Copyright © 2011-2022 走看看