zoukankan      html  css  js  c++  java
  • 杭电2734----Quicksum(C++)(数字与字符的关系)

    Quicksum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 8353    Accepted Submission(s): 5614


     

    Problem Description
    A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

    For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

    A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

    ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650
     
    Input
    The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.
     
    Output
    For each packet, output its Quicksum on a separate line in the output.
     
     
    Sample Input
     
    ACM MID CENTRAL REGIONAL PROGRAMMING CONTEST ACN A C M ABC BBC #
     
    Sample Output
     
    46 650 4690 49 75 14 15

    Source

    Mid-Central USA 2006

    题解:

    #include<cstdio>
    #include<iostream>
    using namespace std;
    #include<string>
    int main()
    {
        string str ;
        while (getline(cin, str) && str != "#")
        {
            int sum = 0;
            for (int i = 0; i < str.length(); i++)
            {
                if (str[i] != ' ')
                    sum = sum + (str[i]-'A'+1)*(i + 1);
            }
            cout << sum << endl;
        }
        return 0;
    }

    永远热泪盈眶。
  • 相关阅读:
    PHP函数篇详解十进制、二进制、八进制和十六进制转换函数说明
    TP5安装workerman版本的坑
    下载git2.2.1并将git添加到环境变量中
    RedHat安装git报错 expected specifier-qualifier-list before ‘z_stream’
    Git出现fatal: Unable to find remote helper for 'https'
    ThinkPHP5实现定时任务
    php一行代码获取本周一,本周日,上周一,上周日,本月一日,本月最后一日,上月一日,上月最后一日日期
    git 查看日志记录
    程序员必读之软件架构 读书笔记
    centos7 安装桌面
  • 原文地址:https://www.cnblogs.com/2021WGF/p/14253245.html
Copyright © 2011-2022 走看看