zoukankan      html  css  js  c++  java
  • 杭电2734----Quicksum(C++)(数字与字符的关系)

    Quicksum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 8353    Accepted Submission(s): 5614


     

    Problem Description
    A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

    For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

    A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

    ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650
     
    Input
    The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.
     
    Output
    For each packet, output its Quicksum on a separate line in the output.
     
     
    Sample Input
     
    ACM MID CENTRAL REGIONAL PROGRAMMING CONTEST ACN A C M ABC BBC #
     
    Sample Output
     
    46 650 4690 49 75 14 15

    Source

    Mid-Central USA 2006

    题解:

    #include<cstdio>
    #include<iostream>
    using namespace std;
    #include<string>
    int main()
    {
        string str ;
        while (getline(cin, str) && str != "#")
        {
            int sum = 0;
            for (int i = 0; i < str.length(); i++)
            {
                if (str[i] != ' ')
                    sum = sum + (str[i]-'A'+1)*(i + 1);
            }
            cout << sum << endl;
        }
        return 0;
    }

    永远热泪盈眶。
  • 相关阅读:
    深入理解javascript原型和闭包(10)——this
    深入理解javascript原型和闭包(9)——简述【执行上下文】下
    深入理解javascript原型和闭包(8)——简述【执行上下文】上
    深入理解javascript原型和闭包(7)——原型的灵活性
    golang 处理 json 结构体
    git push 时用户的配置
    vscod如何自定义 python虚拟环境
    Python实现图片的base64编码
    解决vscode中golang插件依赖安装失败问题
    (转)vscode实现markdown流程图
  • 原文地址:https://www.cnblogs.com/2021WGF/p/14253245.html
Copyright © 2011-2022 走看看