zoukankan      html  css  js  c++  java
  • 杭电OJ2005---第几天?(c++)

    Problem Description

    给定一个日期,输出这个日期是该年的第几天。

    Input

    输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。

    Output

    对于每组输入数据,输出一行,表示该日期是该年的第几天。

    Sample Input

    1985/1/20 2006/3/12

    Sample Output

    20 71

    题解:

    #include<cstdio>
    #include<iostream>
    #include<cmath>
    using namespace std;
    #define PI 3.1415927
    int main()
    {
        int x, y,m,ans;
        int s1[11] = { 31,29,31,30,31,30,31,31,30,31,30};
        int s2[11] = { 31,28,31,30,31,30,31,31,30,31,30};
        while (cin >> x)
        {
            cin.ignore();
            cin >> y;
            cin.ignore();
            cin >> m;
            ans = 0;
            if (x % 4 == 0 && x % 100 != 0 || x % 400 == 0)
                for (int i = 0; i < y-1; i++)
                    ans += s1[i];
            else
                for (int i = 0; i < y-1; i++)
                    ans += s2[i];
            ans += m;
            cout << ans << endl;
        }
        return 0;
    }
    永远热泪盈眶。
  • 相关阅读:
    对象实例化内存布局与访问定位
    方法区

    本地方法栈
    本地方法接口
    虚拟机栈
    程序计数器
    运行时数据区概述及线程
    自学》2.网页弹窗计算商品价格
    自学》1.用网站发邮件
  • 原文地址:https://www.cnblogs.com/2021WGF/p/14253251.html
Copyright © 2011-2022 走看看