zoukankan      html  css  js  c++  java
  • 1002

    This time, you are supposed to find A+BA+BA+B where AAA and BBB are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

    K N1​​aN1 N2​​aN2 ... NK​​aNK​​​​

    where K is the number of nonzero terms in the polynomial, Ni and aNi​​​​ ( i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10 1K100NK​​<<N2​​<N1​​1000.

    Output Specification:

    For each test case you should output the sum of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

    Sample Input:

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    

    Sample Output:

    3 2 1.5 1 2.9 0 3.2

    题目:

    程序输入为两行:每行为一个多项式,求两个多项式之和。

    输入规格:

    按 K  N1  aN1  N2  aN2......NK  aNK,K代表的是多项式的非零项个数,Ni是指数,aNi是系数,其中1<=K<=10,N1到Ni的范围区间是 1<= NK <= ......<=N2<= N1 <= 1000;遇到相同的指数,系数进行累加,从而合并成一个多项式。

    输出规范:

    对于每个测试用例,您应该用与输入相同的格式在一行中输出A和B的和。注意,每一行的末尾必须没有多余的空间。请精确到小数点后一位。

    样例输入:

    2 1 2.4 0 3.2

    2 2 1.5 1 0.5

    样例输出:

    3 2 1.5 1 2.9 0 3.2

    题解:

    设立c数组,长度为指数的最大值,c[i] = j表示指数i的系数为j,接收a和b输入的同时将对应指数的系数加入到c中,累计c中所有非零系数的个数,然后从后往前输出所有系数不为0的指数和系数。

    实现关键:1.格式问题,末尾无空格。2.系数和为零的项不输出。

    #include <iostream>
    using namespace std;
    int main() {
        float c[1001] = {0};//设立C数组,表示指数i的系数为j 
        int m, n, t;
        float num;
        scanf("%d", &m);//输入第一个非零项的个数 
        for (int i = 0; i < m; i++) {
            scanf("%d%f", &t, &num);//输入指数和系数 
            c[t] += num;
        }
        scanf("%d", &n);//输入第二个非零项个数 
        for (int i = 0; i < n; i++) {
            scanf("%d%f", &t, &num);//输入指数和系数 
            c[t] += num;//第一个和第二个相加 
        }
        int cnt = 0;//多项式的个数 
        for (int i = 0; i < 1001; i++) {
            if (c[i] != 0) cnt++;
        }
        printf("%d", cnt);
        for (int i = 1000; i >= 0; i--) {
            if (c[i] != 0.0)
                printf(" %d %.1f", i, c[i]);
        }
        return 0;
    }
  • 相关阅读:
    项目管理原则
    开发规范
    讲故事-如何才算确认了需求
    关于概要设计
    jQuery操作
    IE8,IE9,IE10绿色版,以及ColorPix
    机务UI设计小节
    Abstract Factory
    Flyweight
    Chain of Responsibility
  • 原文地址:https://www.cnblogs.com/2228212230qq/p/10887830.html
Copyright © 2011-2022 走看看