zoukankan      html  css  js  c++  java
  • POJ 2255 Tree Recovery

    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
    This is an example of one of her creations: 

    D 
    / \ 
    / \ 
    B E 
    / \ \ 
    / \ \ 
    A C G 
    / 
    / 
    F 

    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
    She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
    However, doing the reconstruction by hand, soon turned out to be tedious. 
    So now she asks you to write a program that does the job for her! 

    Input

    The input will contain one or more test cases. 
    Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
    Input is terminated by end of file. 

    Output

    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

    Sample Input

    DBACEGF ABCDEFG BCAD CBAD

    Sample Output

    ACBFGED CDAB
    #include <stdio.h> //由先序中序求后序
    #include <stdlib.h> 
    #include <string.h> 
    int n; 

    char void ct(*f,char *s,int fl,int fr,int sl,int sr) 

    { 
       int i,n; if(fl==fr) 
      { 
       printf("%c",f[fl]); return ; 
      } 
       for(i=sl;i<=sr;i++) 
         if(s[i]==f[fl]) 
            break; 
      n=i-sl;
      if(i==sl&&sr-sl>0) 
    { 
    ct(f,s,fl+1,fr,sl+1,sr);
      printf("%c",f[fl]); 
       return ; 
    } else 
       if(i==sr&&sr-sl>0) 
       { 
        ct(f,s,fl+1,fr,sl,sr-1);
        printf("%c",f[fl]);
        return ;
       } 
      ct(f,s,fl+1,fl+n,sl,i-1); 
      ct(f,s,fl+n+1,fr,i+1,sr); 
      printf("%c",f[fl]); 
    return ; 
    } 
    int main() 
    { 
      int i,j; 
      char f[33],s[33]; 
       while(scanf("%s%s",f,s)!=EOF) 
      { 
        n=strlen(f); 
        ct(f,s,0,n-1,0,n-1); 
        printf("\n"); 
      } 
      return 0; 
    }
                                                               ------江财小子
  • 相关阅读:
    jQuery$命名冲突问题解决方法
    微信小程序开发工具 ubuntu linux版本
    阿里云Https通配符证书购买
    vs2017安装
    规范与标准
    Jvm远程监控
    Bash笔记
    Html5前端笔记
    Php7 开发笔记
    webpack笔记
  • 原文地址:https://www.cnblogs.com/372465774y/p/2421696.html
Copyright © 2011-2022 走看看