zoukankan      html  css  js  c++  java
  • HDU 3371 Connect the Cities

    Connect the Cities

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4014    Accepted Submission(s): 1193


    Problem Description
    In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
     
    Input
    The first line contains the number of test cases.
    Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
    To make it easy, the cities are signed from 1 to n.
    Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
    Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
     
    Output
    For each case, output the least money you need to take, if it’s impossible, just output -1.
     
    Sample Input
    1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
     
    Sample Output
    1
     
    Author
    dandelion
     
    Source
     
    Recommend
    lcy

    //最小生成树、就是把已经连接的边权值设为0

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <cmath>
    #include <queue>
    #define N 503
    using namespace std;
    int map[N][N];
    bool b[N];
    int n;
    void prim()
    {
       memset(b,0,sizeof(b));
       b[1]=1;
       int i,j,t=n,min,sum=0;
        while(--t)
        {    min=1000;
            for(i=2;i<=n;i++)
             if(!b[i]&&map[1][i]<min)
               min=map[1][i],j=i;
            if(min==1000) break;
            b[j]=1;
            sum+=min;
            for(i=2;i<=n;i++)
              if(!b[i]&&map[1][i]>map[j][i])
               map[1][i]=map[j][i];
        }
        if(min==1000)
         printf("-1\n");
        else
         printf("%d\n",sum);
    }
    int main()
    {
        int m,l,k,t,T,i,j;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d%d",&n,&m,&l);
            for(i=1;i<=n;i++)
              for(j=1;j<=n;j++)
                map[i][j]=1000;
            while(m--)
            {
                scanf("%d%d%d",&i,&j,&k);
                map[i][j]=map[i][j]>k?k:map[i][j];
                map[j][i]=map[i][j];
            }
           while(l--)
           {
               scanf("%d%d",&t,&i);
               while(--t)
               {
                   scanf("%d",&j);
                   map[i][j]=map[j][i]=0;
                   i=j;
               }
           }
           prim();
        }
        return 0;
    }

  • 相关阅读:
    Single Number II
    Best Time to Buy and Sell Stock
    Linked List Cycle
    Single Number
    Max Points on a Line
    Strategy
    LRU Cache
    Word Break II
    Text Justification
    Median of Two Sorted Arrays
  • 原文地址:https://www.cnblogs.com/372465774y/p/2593102.html
Copyright © 2011-2022 走看看