zoukankan      html  css  js  c++  java
  • POJ 3667 Hotel

    Hotel
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 6681   Accepted: 2777

    Description

    The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

    The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

    Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ XiN-Di+1). Some (or all) of those rooms might be empty before the checkout.

    Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

    Output

    * Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

    Sample Input

    10 6
    1 3
    1 3
    1 3
    1 3
    2 5 5
    1 6
    

    Sample Output

    1
    4
    7
    0
    5
    

    Source

    //线段树的经典、区间操作

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    #include <vector>
    #include <cmath>
    #define lson l,m,k<<1
    #define rson m+1,r,k<<1|1
    #define N 50000
    using namespace std;
    struct node
    {
        int lm,rm,m,len;//lm,rm代表以被零覆盖的端点开始的最长零序列
        short cover;
    };
    node st[N<<2];
    void up(int &k)
    {
        int ls=k<<1,rs=k<<1|1;
        st[k].lm=st[ls].lm==st[ls].len?st[ls].len+st[rs].lm:st[ls].lm;
        st[k].rm=st[rs].rm==st[rs].len?st[rs].len+st[ls].rm:st[rs].rm;//手贱
       //喜欢复制粘贴、然后因为这里ls忘记改成rs,郁闷了一早上,还好1Y了
        st[k].m=max(max(st[ls].m,st[rs].m),st[ls].rm+st[rs].lm);
        st[k].m=max(max(st[k].lm,st[k].rm),st[k].m);
    }
    void down(int &k)
    {
        st[k<<1].cover=st[k<<1|1].cover=st[k].cover;
        st[k<<1].lm=st[k<<1].rm=st[k<<1].m=st[k].cover?0:st[k<<1].len;
        st[k<<1|1].lm=st[k<<1|1].rm=st[k<<1|1].m=st[k].cover?0:st[k<<1|1].len;
        st[k].cover=-1;
    }
    void build(int l,int r,int k)
    {
        st[k].cover=0;
        st[k].len=r-l+1;
        if(l==r)
          {
              st[k].lm=st[k].rm=st[k].m=1;
              return;
          }
        int m=(l+r)>>1;
        build(lson);
        build(rson);
        up(k);
    }
    bool flag;
    void update(int &L,int &R,int l,int r,int k)
    { //printf("%d %d",l,r);
        if(L<=l&&R>=r)
        {
            st[k].lm=st[k].rm=st[k].m=flag?0:st[k].len;
            st[k].cover=flag;
            return ;
        }
        if(st[k].cover!=-1)
          down(k);
        int m=(l+r)>>1;
        if(L<=m) update(L,R,lson);
        if(R>m)  update(L,R,rson);
        up(k);
       // printf("%d %d %d\n",l,r,st[k].m);
    }
    int Query(int &len,int l,int r,int k)
    {
        if(l==r) return l;
        int m=(l+r)>>1;
        if(st[k].cover!=-1)
           down(k);
        if(len==st[k<<1].m&&len==st[k<<1].len)
           return l;
        if(len<=st[k<<1].m)
          return Query(len,lson);
        if(len<=st[k<<1].rm+st[k<<1|1].lm)
           return m-st[k<<1].rm+1;
        if(len==st[k<<1|1].m&&len==st[k<<1|1].len)
             return m+1;
        return Query(len,rson);
    }
    int main()
    {
        int n,m;
        int op,index,len,e;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            build(1,n,1);

            while(m--)
            {
                scanf("%d",&op);
                if(op==1)
                {
                    scanf("%d",&len);
                    if(st[1].m<len)
                    {
                        printf("0\n");
                        continue;
                    }
                    index=Query(len,1,n,1);
                    printf("%d\n",index);
                    flag=1;e=index+len-1;
                     update(index,e,1,n,1);
                }
                else
                {
                   scanf("%d%d",&index,&len);
                   e=index+len-1;
                   flag=0;
                   update(index,e,1,n,1);//printf("m=%d ",st[1].m);
                }
            }
        }
        return 0;
    }

  • 相关阅读:
    统计学习方法 学习笔记(八):k 近邻法
    统计学习方法 学习笔记(七):拉格朗日对偶性
    统计学习方法 学习笔记(六):序列最小最优化算法SMO
    统计学习方法 学习笔记(五):支持向量机(下)
    统计学习方法 学习笔记(四):支持向量机(中)
    统计学习方法 学习笔记(三):支持向量机(上)
    统计学习方法 学习笔记(二):感知机
    CUDA npp运动检测模块性能测试
    CUDA H624解码性能测试
    利用GPU改善程序性能的一点心得
  • 原文地址:https://www.cnblogs.com/372465774y/p/2602311.html
Copyright © 2011-2022 走看看