zoukankan      html  css  js  c++  java
  • POJ 2777 Count Color

    
    
    Count Color
    
    
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 26788   Accepted: 8003
    
    

    Description

    
    
    Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

    There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

    1. "C A B C" Color the board from segment A to segment B with color C.
    2. "P A B" Output the number of different colors painted between segment A and segment B (including).

    In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.
    
    

    Input

    
    
    First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.
    
    

    Output

    
    
    Ouput results of the output operation in order, each line contains a number.
    
    

    Sample Input

    
    
    2 2 4
    C 1 1 2
    P 1 2
    C 2 2 2
    P 1 2
    
    
    

    Sample Output

    
    
    2
    1
    
    
    

    Source

    
    
    
    //不错的题目哈
    //问一个区间有几种颜色 
    //先成段涂色 统计时遇到纯色就统计下
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #define N 100003
    #define lson l,m,k<<1
    #define rson m+1,r,k<<1|1
    using namespace std;
    int st[N<<2];
    bool T[31];
    void build(int l,int r,int k)
    {
        st[k]=1;
        if(l==r)
         return;
        int m=(l+r)>>1;
        build(lson);
        build(rson);
    }
    void down(int &k)
    {
        st[k<<1]=st[k<<1|1]=st[k];
        st[k]=0;
    }
    int cover;
    void update(int &L,int &R,int l,int r,int k)
    {
        if(L<=l&&R>=r)
         {
             st[k]=cover;
             return ;
         }
         if(st[k])
          down(k);
         int m=(l+r)>>1;
         if(L<=m) update(L,R,lson);
         if(R>m)  update(L,R,rson);
    }
    void query(int &L,int &R,int l,int r,int k)
    {   if(T[st[k]]) return ;//开始没加这句,TLE
        if(L<=l&&R>=r&&st[k])
        {
            T[st[k]]=1;
            return ;
        }
         if(st[k])
          down(k);
        int m=(l+r)>>1;
        if(L<=m) query(L,R,lson);
        if(R>m)  query(L,R,rson);
    }
    int main()
    {
        int L,t,O;
        char op;
        int a,b;
        int c,i;
        while(scanf("%d%d%d",&L,&t,&O)!=EOF)
        {
            build(1,L,1);
            while(O--)
            {
                getchar();
                scanf("%c",&op);
                if(op=='C')
                {
                    scanf("%d%d%d",&a,&b,&cover);
                    if(a>b) swap(a,b);//这个开始也忘记加了 WA
                    update(a,b,1,L,1);
                }
                else
                {
                    memset(T,0,sizeof(T));
                    scanf("%d%d",&a,&b);
                    if(a>b) swap(a,b);
                    query(a,b,1,L,1);
                    for(c=0,i=1;i<=t;i++)
                      if(T[i])
                        c++;
                    printf("%d\n",c);
                }
            }

        }
        return 0;
    }


  • 相关阅读:
    JFinal框架
    shiro认证登录实现
    linux常用的命令
    zookeeper部署到linux操作步骤
    java的冒泡排序
    软件设计的七大原则
    vue知识点整理
    JVM垃圾回收算法
    Sql Server删库了怎么办?跑路是不可能跑路的
    Linux--find用法
  • 原文地址:https://www.cnblogs.com/372465774y/p/2607583.html
Copyright © 2011-2022 走看看