zoukankan      html  css  js  c++  java
  • HDU 2119 Matrix

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1076    Accepted Submission(s): 448
    
    
    Problem Description
    Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .
    
    Your task is to give out the minimum times of deleting all the '1' in the matrix.
     
    
    Input
    There are several test cases.
    
    The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
    The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.
    
    n=0 indicate the end of input.
     
    
    Output
    For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.
     
    
    Sample Input
    3 3 
    0 0 0
    1 0 1
    0 1 0
    0
     
    
    Sample Output
    2
     
    //行列(一整行,一整列)拆分成 X,Y集合,编号1-n 和 1-m
    //某一行列相交有1时,X集合行编号和Y集合相应编号建立连接关系
    //这时二分图的边就对应原图中的1 转化成求最小点覆盖、、、就是求最大匹配
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    #define N 102
    int map[N][N],visit[N],match[N];
    int n,m;
    bool DFS(int k)
    {
        for(int i=1;i<=m;i++)
    	{
    	    if(visit[i]||!map[k][i])
    			continue;
    		visit[i]=1;
    		if(!match[i]||DFS(match[i]))
    		{
    		     match[i]=k;
    			 return true;
    		}
    	
    	}
    	return false;
    }
    int main()
    {
    	int i,j;
        while(scanf("%d",&n),n)
    	{
    		  scanf("%d",&m);
    	      for(i=1;i<=n;i++)
    			for(j=1;j<=m;j++)
    			  scanf("%d",&map[i][j]);
             memset(match,0,sizeof(match));
    		 int cnt=0;
    		 for(i=1;i<=n;i++)
    		 {
    		    memset(visit,0,sizeof(visit));
    			if(DFS(i)) cnt++;
    		 }
             printf("%d\n",cnt);
    	}
        return 0;
    }
    

      

  • 相关阅读:
    IDEA中用jetty启动项目时,url 404
    Mysql 性能查询
    RabbitMQ 安装
    Ubuntu安装kubernetes
    .net 4 调用WCF时报错 Type 'System.Threading.Tasks.Task`1[]' cannot be serialized
    Windows XP SP2上安装.net 4
    angular学习的一些Mark
    [转]对 td 使用 overflow:hidden; 无效的几点错误认识
    静态方法与非静态方法的区别
    二进制字符串的权限管理
  • 原文地址:https://www.cnblogs.com/372465774y/p/2718725.html
Copyright © 2011-2022 走看看