zoukankan      html  css  js  c++  java
  • poj 3687 Labeling Balls

    Labeling Balls
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8225   Accepted: 2234

    Description

    Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

    1. No two balls share the same label.
    2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

    Can you help windy to find a solution?

    Input

    The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

    Output

    For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

    Sample Input

    5
    
    4 0
    
    4 1
    1 1
    
    4 2
    1 2
    2 1
    
    4 1
    2 1
    
    4 1
    3 2
    

    Sample Output

    1 2 3 4
    -1
    -1
    2 1 3 4
    1 3 2 4
    

    Source

     
    //我开始的思路是有点对、只是贪心反了、这个输出的是重量呀、唉、、英语不好
    //反向建图,然后优先选择编号大的给重量大的、、
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    vector <int> v[202];
    int in[202];
    int pt[202];
    int main()
    {
        int T;
        int n,m;
        int a,b;
        int i,k;
        int q;
        scanf("%d",&T);
        while(T--)
        {
            priority_queue<int > Q;
            scanf("%d %d",&n,&m);
            memset(in,0,sizeof(in));
            q=n;
            for(i=0;i<m;i++)
            {
                scanf("%d %d",&a,&b);
                v[b].push_back(a);
                in[a]++;
            }
            for(i=1;i<=n;i++)
             if(in[i]==0)
              Q.push(i);
            int l;
            while(!Q.empty())
            {
                k=Q.top();Q.pop();
                pt[k]=q--;
                l=v[k].size();
                for(i=0;i<l;i++)
                 if(--in[v[k][i]]==0)
                  Q.push(v[k][i]);
            }
            for(i=1;i<=n;i++)
             if(in[i])
              break;
            if(i<=n) printf("-1\n");
            else
            {
                 printf("%d",pt[1]);
                for(i=2;i<=n;i++)
                 printf(" %d",pt[i]);
                 printf("\n");
            }
            for(i=1;i<=n;i++) v[i].clear();
        }
        return 0;
    }
  • 相关阅读:
    查找表包含的页和页所在的表
    一次死锁追踪经历
    SQL语句实现取消自增列属性
    如何修改SQL Server 2005服务器名称
    出身在二三线城市软件工作者的悲哀
    (转)Android 混淆器 ProGuard (一定程度防止反编译)
    《Java 并发编程实战》第一、二章阅读笔记
    在 Visual Studio 2010 中配置 OpenGL 开发环境
    《Java 学习笔记》 第七、八章阅读体验
    2012年上半年阅读书籍清单
  • 原文地址:https://www.cnblogs.com/372465774y/p/2766302.html
Copyright © 2011-2022 走看看