zoukankan      html  css  js  c++  java
  • UVALive 3026 Period KMP 失配函数处理周期的问题

     For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
    
    Input 
    
    The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) � the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
    
    Output 
    
    For each test case, output �Test case #� and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
    
    Sample Input 
    
    3
    aaa
    12
    aabaabaabaab
    0
    
    Sample Output 
    
    Test case #1
    2 2
    3 3
    
    Test case #2
    2 2
    6 2
    9 3
    12 4
    // KMP 失配函数处理周期的问题、 训练指南 P213
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <vector>
    #include <ctype.h>
    #include <stack>
    #include <iostream>
    using namespace std;
    char P[1000010];
    int fail[1000010];
    int main()
    {
       //  freopen("in.txt","r",stdin);
        int i,j,len;
        int n,num=1;
        while(scanf("%d",&n),n)
        {
            scanf("%s",P);
            fail[0]=fail[1]=0;
            printf("Test case #%d\n",num++);
            for(i=1;i<=n;i++)
             {
                 j=fail[i];
                 while(j&&P[i]!=P[j]) j=fail[j];
                 fail[i+1]=P[i]==P[j]?j+1:0;
                 len=i-fail[i];
                 if(fail[i]>0&&i%len==0) printf("%d %d\n",i,i/len);
             }
             printf("\n");
        }
        return 0;
    }


  • 相关阅读:
    内存管理——显式类型转换
    内存管理——隐式类型转换
    数据类型——构造类型——枚举
    构造类型——联合类型
    结构体学习笔记9——结构体大小计算规则
    结构体学习笔记8——内存对齐
    结构体学习笔记7——结构体数组
    结构体学习笔记6——结构体嵌套
    结构体学习笔记5——指针成员与函数成员
    一.js高级(9)深拷贝-浅拷贝的其他方法
  • 原文地址:https://www.cnblogs.com/372465774y/p/3013179.html
Copyright © 2011-2022 走看看