zoukankan      html  css  js  c++  java
  • 1029 Median (25分)

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output Specification:

    For each test case you should output the median of the two given sequences in a line.

    Sample Input:

    4 11 12 13 14
    5 9 10 15 16 17
    

    Sample Output:

    13
    题目分析:利用2个队列 对第二个队列进行在线处理 每次都输出一个最小的值 并且记录此时已经输出值的个数 直到找到中间的值
    #define _CRT_SECURE_NO_WARNINGS
    #include <climits>
    #include<iostream>
    #include<vector>
    #include<queue>
    #include<stack>
    #include<algorithm>
    #include<string>
    #include<cmath>
    using namespace std;
    int main()
    {
        queue<int>a, b;
        int N, M,num;
        cin >> N;
        for(int i=0;i<N;i++)
        {
            scanf("%d", &num);
            a.push(num);
        }
        a.push(INT_MAX);
        cin >> M;
        int count = 0, mid = (N + M-1) / 2;
        for (int i = 0; i < M; i++)
        {
            scanf("%d", &num);
            b.push(num);
            if (count == mid)
            {
                printf("%d", min(a.front(), b.front()));
                return 0;
            }
            else
            {
                if (a.front() < b.front())
                    a.pop();
                else
                    b.pop();
                count++;
            }
        }
        b.push(INT_MAX);
        for (int i = count; i < mid; i++)
        {
            if (a.front() < b.front())
                a.pop();
            else
                b.pop();
        }
        printf("%d", min(a.front(), b.front()));
        return 0;
    }
     
  • 相关阅读:
    用 jQuery Masonry 插件创建瀑布流式的页面
    ecshop标签大全 各个页面常用标签大全
    Logistic Regression Using Gradient Descent -- Binary Classification 代码实现
    Linear Regression Using Least Squares Method 代码实现
    eigen quick reference
    Linear Regression Using Gradient Descent 代码实现
    eigen 笔记2
    eigen 笔记1
    Floyd 判圈算法
    SQL Expression Language Tutorial 学习笔记二
  • 原文地址:https://www.cnblogs.com/57one/p/12005779.html
Copyright © 2011-2022 走看看